Community Forums
Page 1 of 5 123 ... LastLast
Results 1 to 5 of 22

Thread: Setting Virtual Directories/Web Applications to ApplicationPoolIdentity How-To?

  1. #1
    Join Date
    Apr 2002
    Location
    Quakertown, PA
    Posts
    714

    Setting Virtual Directories/Web Applications to ApplicationPoolIdentity How-To?

    Hi all,

    We have a web application which is working fine, but field techs are requesting a change. Our current Application Pool settings are attached. We want that to be assigned a specific user/pswd entered during the install. So, I don't envision anything changing there.

    We currently set the the same user on the Web Application and a Virtual Directory, but we would like to change those to ApplicationPoolIdentity. I don't see that option in the Application or Virtual Directory settings. I've attached the current security settings for that and I don't see a specific option to set the desired identity.

    Is it possibly a combination of some settings or will leaving the username/pswd blank default to ApplicationPoolIdentity at install time?

    Thanks in Advance!
    Attached Images Attached Images   
    Any help is GRRRRRReatly Appreciated!

  2. #2
    Join Date
    May 2007
    Location
    Northern Minnesota
    Posts
    807
    If you look to the right of the Process Model - Identity field (off the edge of your screen shot) there is an arrow for a dropdown.
    Clicking on that will give you choices. Does one of them work for you?

    NetworkService
    LocalService
    LocalSystem
    SpecificUser
    ApplicationPoolIdentity <-- ?

  3. #3
    Join Date
    Apr 2002
    Location
    Quakertown, PA
    Posts
    714
    Quote Originally Posted by rguggisberg View Post
    If you look to the right of the Process Model - Identity field (off the edge of your screen shot) there is an arrow for a dropdown.
    Clicking on that will give you choices. Does one of them work for you?

    NetworkService
    LocalService
    LocalSystem
    SpecificUser
    ApplicationPoolIdentity <-- ?
    That is on the Application Pool itself and that is set up OK as far as I know. If I change that to ApplicationPoolIdentity, does that trickle down to the authentication setting on the apps/virtual directories? I guess I could try that but I don't know if setting that overides the username and password that is set during install on the Application Pool. The user set for the Application Pool during install is what is to be used there.

    As the install stands now, with the setting shown, here is what the techs change in the field and what I want to accomplish with the install...

    Open IIS.
    Select OurApplication
    In the IIS section of the center pane (icons) right click on Authentication, select Open Feature
    Select Anonymous Authentication
    Right Click and choose Edit
    Select Application Pool Identity.

    So, after install, they don't want to have to do that as the install should set that to ApplicationPoolIdenty. As you can tell, I'm not IIS expert.
    Any help is GRRRRRReatly Appreciated!

  4. #4
    Join Date
    May 2007
    Location
    Northern Minnesota
    Posts
    807
    Ok... If I understand correctly I think you want to go to
    IIS
    Web Sites
    Name Of Your Web Site

    Security
    Enable Anonymous Access = Yes
    Anonymous User Name = [User Name Property Entered on Install]
    Anonymous Password = [Password Property Entered on Install]

  5. #5
    Join Date
    Apr 2002
    Location
    Quakertown, PA
    Posts
    714
    Quote Originally Posted by rguggisberg View Post
    Ok... If I understand correctly I think you want to go to
    IIS
    Web Sites
    Name Of Your Web Site

    Security
    Enable Anonymous Access = Yes
    Anonymous User Name = [User Name Property Entered on Install]
    Anonymous Password = [Password Property Entered on Install]
    All of that is set currently in/by our install. Anonymous Access is set to yes and results as such post install. Each web application/virtual directory then has the user name and password entered during install set in their properties as well as the Application Pool.

    However, field techs have to go into each app/directory and...

    Select Anonymous Authentication
    Right Click and choose Edit
    Select Application Pool Identity.

    So, I want this setting to be set during or by the install so users or techs don't have to do so afterwards.
    Any help is GRRRRRReatly Appreciated!

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •