Community Forums
Results 1 to 2 of 2

Thread: InstallScript project Component Self Registration not working

  1. #1
    Join Date
    Jun 2011
    Posts
    38

    Question InstallScript project Component Self Registration not working

    Components are set to be self registering, files are installed, no missing dependencies but InstalShield cannot register the DLL's in any of the components. The error shows the correct path but is giving "The Specified module could not be found". I can then complete the install, go to the path shown on the error dialog and manually register the dll's without issue. When the error comes up I have also verified the files are there.
    Does anyone know what InstallShield uses to do the self registration? This is on several different Windows OS' and it is ran as a 64bit installation.

  2. #2
    Join Date
    Jun 2017
    Posts
    17
    See whether you are able to register the DLL when the error message popped up, if it got failed then see whether you need to do the registration in a particular order. Some time the module registration may fail due to the absence of the dependent module. This can be resolved by setting the order of registration in Installshield.


    Quote Originally Posted by jstarbird View Post
    Components are set to be self registering, files are installed, no missing dependencies but InstalShield cannot register the DLL's in any of the components. The error shows the correct path but is giving "The Specified module could not be found". I can then complete the install, go to the path shown on the error dialog and manually register the dll's without issue. When the error comes up I have also verified the files are there.
    Does anyone know what InstallShield uses to do the self registration? This is on several different Windows OS' and it is ran as a 64bit installation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •