Community Forums
Results 1 to 3 of 3

Thread: Cache path for packages in suite projects

  1. #1
    Join Date
    Jan 2013
    Posts
    16

    Cache path for packages in suite projects

    Hi,

    Installshield 2018 includes prerequisite for SQL Server 2014 Express SP2. I use this prerequisite in a Suite Project.

    During the installation of this Suite Project, SQLEXPR_x64_ENU.exe is extracted in %localappdata%\Downloaded Installations\{GUID}. On some machines, probably depending on the length of the Windows account name, the SQLEXPR_x64_ENU.exe installation failed with the following error:

    SQL Server installation media on a network share or in a custom folder can cause installation failure if the total length of the path exceeds 260 characters. To correct this issue, utilize Net Use functionality or shorten the path name to the SQL Server setup.exe file.

    (the error is the same when starting the installation outside the Suite Project)

    To work around this problem, I have to change the cache path of the SQL Server package. I can use:
    - Other locations like WindowsFolder, CommonDocuments... none of these folders suit me.
    - A hard-coded value: it's very dirty.
    - According to the InstallShield help, a formatted expression that contain a property name: perfect, that's what I need!

    Quote Originally Posted by InstallShield help
    When you type a value for this setting, you can include one or more formatted expressions that contain property names, environment variable references, and other special strings; at run time, the installation expands the values of these expressions.
    Unfortunately, when I apply a custom property to the package cache path (ie: [MyProperty]), I get the following error:

    Invalid path entered. Make sure you enter a valid folder location.

    So... is there a way to use a property as a cache path, initialized by the user or a custom action?

    Thanks for help!

    Adrien

  2. #2
    Join Date
    Jul 2003
    Location
    North Kingstown, RI, USA
    Posts
    1,351
    I replicated the behavior. I am able to get around it by opening the suite project in Notepad++ and editing the value manually. The test project compiles successfully.
    Regards,
    Dan Lee

    Release Engineer

  3. #3
    Join Date
    Jan 2013
    Posts
    16
    Wow, it works like a charm, thank you very much!

    For those who would have the same need, simply save your Suite Project with a package cache path that you can search easily (ie: [LocalAppDataFolder]Downloaded InstallationsXXX). Then:

    1. Open your .issuite file in a text editor.
    2. Search your custom cache path. You will see something like this:
      Code:
      <Setup>
      	<Parcels>
      		<Exe>
      			<Package Name="[LocalAppDataFolder]Downloaded InstallationsXXX">
      			</Package>
      		</Exe>
      	</Parcels>
      </Setup>
    3. Update this path as needed (ie: Name="[MyCachePath]").
    4. That's all. If you reopen your Suite Projet, you can see [MyCachePath] as cache path for this package.

    Nice trick, thanks again

    Adrien

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •