A customer is experiencing problems with our msi running on a fresh install of Windows 10 Army Gold Master. Custom actions are failing. This is an msi created with InstallShield 2009, Version 6, Service Pack 2. All other systems (Win 10, Win 8, Win 7, Server 2008, Server 2012) we've tested against work without issue so we believe the problem is not with the msi itself.

There are several forum posts showing the same error. Two of them showed no replies and a third was resolved by performing a "repair" install of InstallShield 2008. We've already tried a "repair" install with no improvements.

We are unable to obtain a copy of the Army edition of Win10, but the customer is willing to work with us. I'm hoping someone can share debugging techniques for this type of problem. Below is logging from the customers install pointing to an issue with the ISRT.dll.

MSI (c) (AC:CC) [17:12:50:528]: Doing action: CheckForPubKey
Action 17:12:50: CheckForPubKey.
Action start 17:12:50: CheckForPubKey.
MSI (c) (AC:7C) [17:12:53:700]: Invoking remote custom action. DLL: C:\Users\WILLIA~2.BEC\AppData\Local\Temp\MSI20DA.tmp, Entrypoint: f13
InstallShield 17:12:53: Running InstallScript function f13
InstallShield 17:12:53: Using temp folder C:\Users\WILLIA~2.BEC\AppData\Local\Temp\{142D2084-D97D-42FF-9C89-B509D3B8FA48}
InstallShield 17:12:53: Installing engine...
InstallShield 17:12:53: Using product language 1033
InstallShield 17:12:53: Extracting support file setup.inx to C:\Users\WILLIA~2.BEC\AppData\Local\Temp\{142D2084-D97D-42FF-9C89-B509D3B8FA48}\setup.inx
InstallShield 17:12:53: Opening stream of file C:\Users\WILLIA~2.BEC\AppData\Local\Temp\MSI20DA.tmp
InstallShield 17:12:53: Extracting support file ISRT.dll to C:\Users\WILLIA~2.BEC\AppData\Local\Temp\{142D2084-D97D-42FF-9C89-B509D3B8FA48}\ISRT.dll
InstallShield 17:12:54: Extracting support file IsConfig.ini to C:\Users\WILLIA~2.BEC\AppData\Local\Temp\{142D2084-D97D-42FF-9C89-B509D3B8FA48}\IsConfig.ini
InstallShield 17:12:54: Extracting support file _isres1033.dll to C:\Users\WILLIA~2.BEC\AppData\Local\Temp\{142D2084-D97D-42FF-9C89-B509D3B8FA48}\_isres.dll
InstallShield 17:12:54: Extracting support file String1033.txt to C:\Users\WILLIA~2.BEC\AppData\Local\Temp\{142D2084-D97D-42FF-9C89-B509D3B8FA48}\String1033.txt
InstallShield 17:12:54: Skipping optional support file _isuser1033.dll
InstallShield 17:12:54: Detected X64 OS
InstallShield 17:12:54: Extracting support file ISBEWX64.exe to C:\Users\WILLIA~2.BEC\AppData\Local\Temp\{142D2084-D97D-42FF-9C89-B509D3B8FA48}\ISBEW64.exe
InstallShield 17:12:54: Setting script cmdline...
InstallShield 17:12:54: ProductCode is {FC6F17E8-AF26-453F-9FF6-A488B745DA32}
InstallShield 17:12:54: Initializing Engine
InstallShield 17:12:54: Failed to Invoke __ISRTInit, error is 0x80020009
InstallShield 17:12:54: InitScript operation failed, error is 0x80020009
InstallShield 17:12:54: Failed to invoke __ISRTUninit, error is 0x80020009
InstallShield 17:12:54: Initialize() Failure, Failed to Initialize script support, Error = 0x80020009
MSI (c) (AC:7C) [17:12:54:965]: NOTE: custom action CheckForPubKey unexpectedly closed the hInstall handle (type MSIHANDLE) provided to it. The custom action should be fixed to not close that handle.
Action ended 17:12:55: CheckForPubKey. Return value 1.

Cheers,
George