Community Forums
Page 2 of 2 FirstFirst 12
Results 6 to 8 of 8

Thread: Scanning VMWare Infrastructure

  1. #6
    Join Date
    May 2010
    Melbourne, Australia
    The "A connection with the server could not be established" error certainly suggests a network connectivity sort of problem (as opposed to anything to do at the application software layer).

    A couple more thoughts:

    1. What version of VMware software is running on the server? Check that it is a version that is supported by the FlexNet Manager Suite release you are using, including that it is not a free VMware ESXi install (which doesn't expose the APIs required to gather the information needed here).
    2. Is it possible that the web browser is configured to go through a web proxy to reach the VMware server? The beacon & ESXQuery tool will likely not be using any web proxy, which could explain the browser being able to connect but the beacon failing to connect.

    Chris @ Flexera

  2. #7
    Join Date
    Jan 2018
    I've verified connectivity from the FNMS Beacon via the ESXQuery tool. In addition, I've loosened up some ACLs for the ports (80 and 443) listed as necessary for the VMWare scanning components to work. The rule fires and completes, however in the actual Inventory phase, the only information provided by the beacon is the following log entry -
    2018-02-13 09:57:46,360 [.VirtualizationVisitor|Async] [INFO ] No inventory gathered for device '<vcenter>' because discovery did not find the service on the device.

    The ESXQuery is able to download an inventory without issue.

  3. #8
    Join Date
    Sep 2017
    We've had the same issue with various vCenters. More and more are being upgraded to vCenter 6.5, and then we can't use the esxquery script as a workaround any more.

    Additional troubleshooting steps Flexera technical support has tried:

    - Ensure the Discovered Device exists; if not create it
    - Ensure the Discovered Device has the correct DNS domain and FQDN that can be discovered from the beacon
    - Set up the Target to use the Discovered Device name instead of IP address
    (wait... sometimes this takes a day or two to work)

    - Change mgsipScan options using registry keys on the beacon <- would recommend opening a case with Flexera to get specifics on how to do this

    I'll be interested to hear how you get yours solved!

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts