Community Forums
Page 1 of 3 123 LastLast
Results 1 to 5 of 13

Thread: Translate from IS6.3.... Help needed !

  1. #1
    Join Date
    Dec 2017
    Location
    Grenoble / France
    Posts
    10

    Translate from IS6.3.... Help needed !

    Hello, I am new to IS2015..
    In my company, all our installers (10) are based on IS6.3 + PackageForTheWeb...
    Those installer are invoked by some packaging scripts that also manage Clearcase file updating and others "in house" stuff.
    So we had to use XP (in a virtual machine) in order to make it worj since IS6.3 do not work on W7x64...

    So I was aked to migrate to IS2015...
    I really want to find an automatic way to translate my IS6.3 project into IS2015... but the automatic import import fails to do that.
    I am affraid about the idea that I have to rewrite my 10 installers projets...

    Is it possible (or not) to automaticaly translate my IS6.3 projects into IS2015 one ??
    If yes how to do that ?

    If no, what do you suggest me ?

    I tried to build a basic MSI project but fall into many issues such as
    - Cannot build INSTALLDIR from Product Name (or other variable) -> Should I use an InstallScript project and customize TARGETDIR ??
    - It's a pity to integrate MY vc_redist and MY .Net4.5 as prerequisite into the setup.exe single exe
    - Where can I find the command line in order to automate creating setup.exe from my script ? I used to call ISBuild -p <miproject.ipr> -m <mymedia> -r then after pftwwiz.exe <myfile> -a

    thanks for your help.

  2. #2
    Join Date
    Dec 2001
    Location
    Bellheim, Rheinland-Pfalz, Germany
    Posts
    122
    I have also a project that I have migrated from IS6.3 to IS 7.0 to IS 9.0 to IS 2010 to IS 2016.

    And that worked. But in each release I have to update the things that had changed.

    What I can offer you is, that if you have a project that you can send me I will try to migrate through all my InstallShield versions and check were it run into trouble.

    regards

    Markus

  3. #3
    Join Date
    Dec 2017
    Location
    Grenoble / France
    Posts
    10
    Quote Originally Posted by MarkusLatz View Post
    ...
    What I can offer you is, that if you have a project that you can send me I will try to migrate through all my InstallShield versions and check were it run into trouble.
    ...
    Markus
    Hi Markus,

    many thanks for your answer and many other thanks for your proposal !

    Attached is 2 ZIPs file of one of my installer project (IS6.3). Since I don't know if the source files should exist in order your translation works, I have also ZIPPED them so... it's quite huge:
    • DiaTech.7z (287M) is the ZIP file containing IS6.3 files AND the compiled MEDIA files (of my last build)
    • Files.7z (262M) is the ZIP file of my source files. The installers files refers to them using relative path (starting with ..\files\*)


    Both ZIP should be UNZIPPED into the same directory. They must be sibling items.

    Since I am using IS2015 (no maintenance to upgrade to 2016 !) You can Stop your conversion at IS2010.

    ... hummm, it looks like the Attachments process fails... I am unable to attach my ZIPs.
    So I put them in our FTP. Here are the links:
    ftp://temento-ftp:temento.com@87.240...age/DiaTech.7z
    ftp://temento-ftp:temento.com@87.240...rtage/Files.7z

    I also let you my email : frederic.prin@temento.com

    Please let me know if the download works !

  4. #4
    Join Date
    Dec 2017
    Location
    Grenoble / France
    Posts
    10
    Quote Originally Posted by MarkusLatz View Post
    ...
    What I can offer you is, that if you have a project that you can send me I will try to migrate through all my InstallShield versions and check were it run into trouble.
    ...
    Markus
    oops my post seems to have failed... I start again.

    So I was saying many thanks for your proposal.
    Since I use IS2015 you can stop with the nearest below version you have that seems to be IS2010.

    Here below are the 2 zips needed to build one of my installer (FTP links since attachment on this forum seems to fail...)



    You must unzip this to archive on the same directory since they must be sibling items in order the IS project can access the source files using relative ..\Files\* path.

    Let me know if you need more material or details or info or wtahever (coffe will be difficult to pass into ethernet wires or wifi waves...)

    Here is my email in order not to waste the forum. frederic.prin@temento.com

    and once again many thanks for your help !

    Hope to heard from you very soon.

    best regards,

  5. #5
    Join Date
    Dec 2017
    Location
    Grenoble / France
    Posts
    10

    to Markus

    Quote Originally Posted by MarkusLatz View Post
    ...
    What I can offer you is, that if you have a project that you can send me I will try to migrate through all my InstallShield versions and check were it run into trouble.
    ...
    Markus
    oops my post seems to have failed... I start again.

    So I was saying many thanks for your proposal.
    Since I use IS2015 you can stop with the nearest below version you have that seems to be IS2010.

    Here below are the 2 zips needed to build one of my installer (FTP links since attachment on this forum seems to fail...)



    You must unzip this to archive on the same directory since they must be sibling items in order the IS project can access the source files using relative ..\Files\* path.

    Let me know if you need more material or details or info or wtahever (coffe will be difficult to pass into ethernet wires or wifi waves...)

    once again many thanks for your help !

    Hope to heard from you very soon.

    best regards,

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •