Community Forums
Results 1 to 1 of 1

Thread: Error The installation of Microsoft Visual C++ 2005 SP1 Redist appears to have failed

  1. #1
    Join Date
    Jul 2017
    Posts
    9

    Error The installation of Microsoft Visual C++ 2005 SP1 Redist appears to have failed

    Hi. When we do upgrades we just started getting the error message above. However, if I navigate to the PreReq folder (C:\ProductName\ISSetupPrerequisites\{AAEC4BE2-1C6B-45E0-B33D-0D657A05F292}) and run vcredist_x86.exe and the go to the other prereq folder (C:\ProductName\ISSetupPrerequisites\{8034C99E-3BC0-4E53-BC6E-02E3D8CF5378}) (in this order) it works fine and installs. I assume one of these is for C++ 2005 and one is for the SP1 version, but I'm not sure which is which. I assume that the first one is for the first version and the second is for the SP1, cause if I install them in the reverse order it fails. Interestingly neither is selected as a pre-req on the Redistributables tab in IS. So the problem may be the order in which it's trying to install them. I don't even see C++ 2005 (non-SP1) in the list of Redistributables, but for some reason two vcredist_x86.exe files are included in the release and when run in the right order (outside of the install) they work fine.

    So how can I change the order in the installer or just get this to work? I reverted all of the changes in my .ism file to back before this started happening and that hasn't helped. I've attached the vcredist_x86.log so maybe that can help.

    Thanks for any help you can provide!

    Ben
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •