Community Forums
Results 1 to 4 of 4

Thread: Prerequisite is not installed on the machines (VC++ 2015) IS 2016 Express

  1. #1
    Join Date
    Jan 2015
    Posts
    4

    Prerequisite is not installed on the machines (VC++ 2015) IS 2016 Express

    Hello

    trying to make an installer where i have loaded the Crystal Reports Merge Module. This works well to install. It requires "Microsoft Visual C ++ Redistributable Package (x86)." I check it from Redistributable (Installshield Prerequisite) and download it. Then i Build the installation and trying to install on a computer that does not have VC 2015 installed. Crystal Reports is installed but not the VC 2015. Why?

    thanks in advance

  2. #2
    Join Date
    Jan 2015
    Posts
    4

    Now VC ++ 2015 install

    Now VC ++ 2015 install. This prq is not good as it only looks at the file version of msvcp140.dll and not on the entire package. In my case (multiple computers) I only had VC ++ 2013 as the latest VC package on the computer but msvcp140.dll had file version 14.11.25xxxx (autoupdate?), so the VC ++ 2015 package does not install, and Crystal Reports 13_0_21 needs it to work. Delete msvcp140.dll from SysWOW64 and System32 and the installation will work as intended. When do we get new prq files for VC ++ 2017?

  3. #3
    Join Date
    Jan 2015
    Posts
    4

    For information

    For information. I leave InstallShield and go to the nearest competitor who seems to care about their customers. Have tried to really get help with the above. If you only have Express, you are completely dependent on others updating Prerequisites, which Flexera does not. If you buy a system for XXX $, you expect updates. Where are .NET 4.7 and 4.6.2, VC ++ 2017 Prerequisites? It's been a long time since they came out, but nobody on flexera updated this. Last VC ++ is 2015 update 3 which does not work when it just looks at file version and the latest .NET framework is 4.6.1, ridiculous!!


    Over and out

  4. #4
    Join Date
    Apr 2008
    Posts
    140

    Visual C++ 2015 x86 runtime update 3

    Can you update the prerequisite with Express? Or create your own after downloading the latest Visual C++ 2015 runtimes from Microsoft?

    This link might help:

    https://community.flexerasoftware.co...when+it+should

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •