Community Forums
Results 1 to 3 of 3

Thread: Create new accounts in FNMS 2017 R1

  1. #1
    Join Date
    Aug 2017

    Create new accounts in FNMS 2017 R1

    This is a fresh install of Flexera 2017 R1 and ad import has been successful after replacing the activedirectoryimport.exe file with the a new .exe as provided on FNMS support site. However, when i try to create a new account in FNMS to assign roles, the search account does not fetch any results.

    Can someone update what is the likely reason that the search is not able to fetch SAM account name from AD.


  2. #2
    Join Date
    May 2010
    Melbourne, Australia
    Some diagnostic steps you may consider to check each step of the flow of this data through the system are:
    1. Review the C:\ProgramData\Flexera Software\Compliance\Logging\ActiveDirectoryImport\ADImport.log file on the beacon for any indication of an error while running the ActiveDirectoryImport.exe process.
    2. If you are running the AD import process on a beacon that is not the application server, review the %TEMP%\ManageSoft\uploader.log file to ensure files are being uploaded from the beacon to its parent successfully (%TEMP% is the temporary folder of the user that the beacon scheduled tasks are configured to run as).
    3. In the Inventory database, ensure that the dbo.ADUser table has been populated with users from the domain. This data is populated when the data from previous steps is imported into the database.
    4. On the application (processing) server, review C:\ProgramData\Flexera Software\Compliance\Logging\ComplianceReader\importer-*.log files for indications of errors while running the ComplianceReader.exe process (there should be a log file here from shortly after the AD import file was processed on the application server).
    5. In the Compliance database, ensure that the dbo.ActiveDirectoryUser table has been populated with users from the domain. This data is populated when the ComplianceReader process runs following population of data in the Inventory database dbo.ADUser table.

    You may find that one of these steps has failed or does not show data, which will point you in the right direction for understanding what has gone on.

  3. #3
    Join Date
    Aug 2017

    Thumbs up Thank you

    Thank you,

    it worked, though the data was populated in the dbo.aduser in FNMSinventory, this data was not populated into the dbo.ActiveDirectoryUsers as the compliance reader for some reason did not run automatically. Further to your input, i went ahead and ran compliancereader.exe from the dotnet bin and that worked like a charm.

    Thanks a ton for the quick response.

    Last edited by nagabhanu; 09-14-2017 at 03:53 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts