Community Forums
Page 2 of 2 FirstFirst 12
Results 6 to 8 of 8

Thread: Delete(FilePath\*.*) not working

  1. #6
    chad.petersen Guest
    It would be nice if you told us what you were working with from the beginning. What a waste of my time.


  2. #7
    Join Date
    Apr 2008

    RemoveFile requires a component

    An entry in RemoveFiles requires a Component to be selected. Does that mean I need to create an entry for every single component? Anyway, I tried using the main install component in my entry. Tried to do delete *.* in the INSTALLDIR on uninstall but nothing seems to happen.

    So I tried making a CA that occurs after RemoveFiles and I was able to successfully remove the subfolders that are preventing me from removing files from INSTALLDIR. I think the InstallExec Sequence is incorrect though - there still are several files left in the installation directory.

  3. #8
    Join Date
    Aug 2007
    Aliso Viejo, CA
    Try DeleteFile(szPath ^ "*.*");

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts