Community Forums
Results 1 to 3 of 3

Thread: Suite Installer: UI DLL: Display Error: The installation of appears to have failed...

  1. #1
    Join Date
    Apr 2008
    Posts
    28

    Suite Installer: UI DLL: Display Error: The installation of appears to have failed...

    We are just testing out Suite installers and I am not 100% sure why this comes up for each installer. The installer themselves works fine. I assume its my Detection Condition, but that also appears to work (since if the key exists it puts it in maintenance mode). Any thoughts would be appreciated.
    Attached Files Attached Files

  2. #2
    Join Date
    Oct 2006
    Location
    Stroud, Glos. U.K
    Posts
    164
    So if you check the installed package key it matches your defined suite detection condition?

    Make sure you're checking the correct part of the registry if you're installing a 32-bit app on a 64-bit host.

  3. #3
    Join Date
    Apr 2008
    Posts
    28
    Quote Originally Posted by Hysteresis View Post
    So if you check the installed package key it matches your defined suite detection condition?

    Make sure you're checking the correct part of the registry if you're installing a 32-bit app on a 64-bit host.
    sorry for the delay, work got in the way haha.

    Anyways. It is an app being installed on a 64bit OS. The key we look for is: HKLM\SOFTWARE\AIR Worldwide\Touchstone\Client and 64bit is True. This key works, as if its found it sends the suite into repair mode.

    Is it possible since the package has redists in it (not the suite) that its causing the issue? The package doesn't take anything more than the .exe so those redists are technically missing.
    Last edited by DonAIR; 08-29-2017 at 02:47 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •