Community Forums
Results 1 to 3 of 3

Thread: Prerequisite for Microsoft ReportViewer 2015

  1. #1
    Join Date
    Dec 2012

    Prerequisite for Microsoft ReportViewer 2015


    The conditions for the ReportViewer 2015 prerequisite did not trigger an install on Windows 10.

    In fact the prq references a key not in my registery where the Report Viewer is working so I don't know how this trigger is supposed to work.

    Here is the registry key specified in the prq:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server 2014 Redist\Microsoft Report Viewer 2015 Runtime

    I don't see "Microsoft Report Viewer 2015 Runtime" under this node.

    How can I determine the correct condition which would trigger the prq to fire?

    Are the PRQ files up-to-date for the latest Windows versiono?


  2. #2
    Join Date
    Dec 2005
    Flexera would be well served by making a public repo where users could modify the prereqs, Wikipedia style. The built in prereqs are just not good enough for the real world, quickly get stale, and prereqs for new products (for instance, new versions of .NET) are not brought out quickly enough. I don't use the ones made by Flexera.

    We've been using ReportViewer for many years and I have made my own over the years (from RV2010 forward). For RV2015, don't look at the registry. The reason is simple - when SQL Server 2014 installs RV, it doesn't use the same registry key as the RV2015 redist. Even though both are ReportViewer version 12.0. Look at the GAC. Use a file condition, comparing versions. The RV2015 redist lays down version 12.0.2402.15 of the following file:


    So, add a file condition where you will run the prereq if 'a file with a certain version exists'. Use the path I just pasted above. Specify 12.0.2402.15 for the version to match. And run if the file's version is LESS THAN (or NOT FOUND).

  3. #3
    Join Date
    Feb 2018

    Adding Windows 10 to ReportViewer 2015.prq

    We also ran into the issue installing ReportViewer 2015 for an application on Windows 10. By looking at the conditions for the Redistributable for ReportViewer 2015, we noted that the Windows 10 operating system was not included. We added the condition to the prerequisites file, rebuilt the install package, and now it installs correctly on Windows 10. The steps we took:
    1. Opened the C:\Program Files (x86)\InstallShield\2016\SetupPrerequisites folder in Windows Explorer
    2. Opened the Microsoft SQL Server 2014 Express System CLR Types (x86).prq with NotePad
    3. Ran NotePad as Administrator and opened the Microsoft ReportViewer 2015.prq
    4. Copied the Windows 10 operating system entry under <operatingsystemconditions> from the CLR Types file.
    <operatingsystemcondition MajorVersion="10" MinorVersion="0" PlatformId="2" CSDVersion=""/>
    5. Pasted the Windows 10 operating system entry under <operatingsystemconditions) in the ReportViewer 2015 file and Saved.
    6. Re-launched Visual Studio and rebuilt the install package

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts