Hello,

We have a software which is developed by using Visul C++ 2005.
We use Installshield version 5.5 Professional Edition to create installer/Software package for the software.

Our requirement is to migrate Installshield(only installshield not the whole project) from version 5.5 Professional Edition to InstallShield 2011.

As per the guideline given in help file of installShield 2011 we have followed the following migration steps.

1. Open InstallShield 2011 and open the file FileName.ipr.
2. Few warning messages displays. we proceed it by clicking OK button.
3. A new file called "FileName.ism" is generated automatically along with some other files. Old files are back up in a newly created folder called "FileName_bak1".
4. Opened "FileName.ism" file in InstallShiel 2011 and modifed the following line of code in “InstallScript".
#include "ifx.h" //Included
//#include "sddialog.h"” //Commented
//nSdDialog = SD_NDLG_LICENSE //Commented
//#include "sddialog.rul" //Commented

4. We create Software installer through command line by writing the following commands in a batch file.

set INSTALL_SHIELD_PATH=C:\Program Files (x86)\InstallShield\2011
set ISBUILD_PROGRAM="%INSTALL_SHIELD_PATH%\System\IsCmdBld.exe"
%ISBUILD_PROGRAM% -p "%DISKNAME%\ishield5.5\FileName\FileName.ism" -r "file-cd-rom"

5. when we Build/Rebuild the batch file,the software installer is generated in the folder "file-cd-rom" without any error but with some warning messages.
6. When we run Setup.exe file of the installer, an error message displayed as shown below and installation terminates.


An error(-5006:0x0070003) has occured while running the setup.

Please make sure you have finished any previous setup and closed other applications.
If the error still occurs,please contact your vender:VENDER_NAME

Error Code: -5006:0x80070003
Error Information:
>SetupNew\setup.cpp(597)
PAPP:SOFTWARE_NAME
PVENDOR:VENDER_NAME
PGUID:714DD....
$17.0.714


7. The problem still exist even after I closed all other applications and try to install it again.

Workaround:
Software Installer works fine when we create it by using the following method.

Project Assistent->Check CD-ROM->Click on Build Installations.

Please help us to resolve this issue on creating installer through command-line batch file.

Thanks in advance.

Regards,
Thiyam