Hi,

We have an MSI that we are trying to install on a new server and we get the following error. Any ideas what the problem is here? The server is windows 2012 R2 and Windows Installer version is 5.0.9600.18333.

Action 09:46:05: ISIISInstall.
MSI (s) (AC:98) [09:46:05:715]: Executing op: CustomActionSchedule(Action=ISIISInstall,ActionType=3073,Source=BinaryData,Target=ISIISInstall,CustomActionData=C:\Users\krakov\AppData\Local\Temp\IISE022.tmp)
MSI (s) (AC:BC) [09:46:05:715]: Invoking remote custom action. DLL: C:\Windows\Installer\MSIF0EC.tmp, Entrypoint: ISIISInstall
MSI (s) (AC:64) [09:46:05:715]: Generating random cookie.
MSI (s) (AC:64) [09:46:05:731]: Created Custom Action Server with PID 1204 (0x4B4).
MSI (s) (AC:98) [09:46:05:778]: Running as a service.
MSI (s) (AC:98) [09:46:05:778]: Hello, I'm your 32bit Elevated Non-remapped custom action server.
InstallShield 09:46:05: This machine does not support legacy objects
InstallShield 09:46:05: InitIISObject
InstallShield 09:46:05: CoGetClassObject(GETAdminBaseCLSID(TRUE) error: -2147221164
InstallShield 09:46:05: Legacy objects not supported
Action 09:46:05: Progress Custom Action.
Action 09:46:05: Progress Custom Action. Creating application pool Xml
InstallShield 09:46:05: CreateAppPoolFunction
InstallShield 09:46:05: GetAdminSection for section 'system.applicationHost/applicationPools' and path 'MACHINE/WEBROOT/APPHOST' and commitpath 'MACHINE/WEBROOT/APPHOST'.
InstallShield 09:46:05: GetAdminSection returned: -2147024846
InstallShield 09:46:05: Error: already using the main configuration file.
InstallShield 09:46:05: Parent element is NULL while searching collection
InstallShield 09:46:05: AppPool does not exist, attempt to create it.
InstallShield 09:46:05: GetAdminSection for section 'system.applicationHost/applicationPools' and path 'MACHINE/WEBROOT/APPHOST' and commitpath 'MACHINE/WEBROOT/APPHOST'.
InstallShield 09:46:05: GetAdminSection returned: -2147024846
InstallShield 09:46:05: Error: already using the main configuration file.
InstallShield 09:46:05: Element is NULL. Can't get collection
InstallShield 09:46:05: Collection is NULL. CreateNewElement failed for: add
InstallShield 09:46:05: PutPropertyValue: sProperty name sValue Xml bIsPath 0
InstallShield 09:46:05: PutPropertyCommon: sProperty name sValue Xml bIsPath 0
InstallShield 09:46:05: Element is NULL while looking for the following property: name
InstallShield 09:46:05: PutPropertyCommon: no property returned for name, don't try to set it now
InstallShield 09:46:05: spCollection NULL in CIisFunctionsVista::AddElement.
InstallShield 09:46:05: pElement NULL in CIisFunctionsVista::AddElement
CustomAction ISIISInstall returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 09:46:06: InstallFinalize. Return value 3.


Thank You