Community Forums
Results 1 to 4 of 4

Thread: installing as system account uses the wrong directory

  1. #1
    Join Date
    Dec 2013
    Posts
    103

    installing as system account uses the wrong directory

    Many desktop management tools are starting to install via the system account. In my case my installer fails. The log yields this:

    MSI (s) (80:44) [20:59:20:956]: Note: 1: 2203 2: C:\Windows\system32\config\systemprofile\AppData\Local\Downloaded Installations\{2A799340-820C-4C05-8DDE-26CA1B685CB8}\Awesome_App.msi 3: -2147287037

    This error means that the file was not found.

    It looks like the installer is not looking in the right place:

    C:\Windows\SysWOW64\config\systemprofile\AppData\Local\Downloaded Installations\{2A799340-820C-4C05-8DDE-26CA1B685CB8}\Awesome_App.msi

    Is there a setting that controls where it should look for the extracted msi file? Usually, this location is for cached installers so that the repair function will work.

    Thanks,

  2. #2
    Join Date
    Dec 2013
    Posts
    103
    Found a post in 2011. Apparently, this has never been fixed.

  3. #3
    Join Date
    Dec 2013
    Posts
    103
    It appears that the issue is directly related to the "Cache MSI Locally" property. If it is on it fails use the correct directory. If it is off then the installation path changes to windows\temp and everything works.

    Since my customer's use of is only using SCCM, then I don't need to cache and enable the repair option. Now I'm on the hunt for a property that will disable the "cache msi locally" from the command-line or set it via custom action when the user is system

  4. #4
    Join Date
    Dec 2013
    Posts
    103
    Installshield 2015 fixes this issue. maybe Installshield 2014, but I haven't tried that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •