Community Forums
Page 1 of 2 12 LastLast
Results 1 to 5 of 7

Thread: Powershell

  1. #1
    Join Date
    May 2010
    Location
    Rochester, NY
    Posts
    51

    Powershell

    Is anyone successfully using Powershell to automate tasks in WFM 2016? I used the example here: but it fails to authenticate. It returns this error message:


    <html><head><title>Object moved</title></head><body>
    <h2>Object moved to <a href="/Account/Login?ReturnUrl=%2fWebServicesRoot%2fIntegration.asmx">here</a>.</h2>
    </body></html>

    I have tried with both basic authentication and passing in the windows credentials of the current user. If I put the url directly into the browser (http://<server name>:81/WebServicesRoot/Integration.asmx) I can access the page without issues.

  2. #2
    Join Date
    May 2010
    Location
    Rochester, NY
    Posts
    51
    Apparently the URL tag didn't work right. Here is the example I used from the knowledgebase.

    https://flexeracommunity.force.com/c...-in-Powershell

  3. #3
    Join Date
    Oct 2007
    Location
    Schaumburg, IL
    Posts
    318
    Hi Ken,

    What PS version are you using? Can you try with the latest PS and see if it makes a difference? I believe PS did not have support for web services until v2 or v3.

    Hope this helps.

    Thanks!
    Alpesh
    Flexera Software Technical Support

  4. #4
    Join Date
    May 2010
    Location
    Rochester, NY
    Posts
    51
    According to $PSVersionTable, I am using version 4.

    PS H:\> $PSVersionTable

    Name Value
    ---- -----
    PSVersion 4.0
    WSManStackVersion 3.0
    SerializationVersion 1.1.0.1
    CLRVersion 4.0.30319.42000
    BuildVersion 6.3.9600.16406
    PSCompatibleVersions {1.0, 2.0, 3.0, 4.0}
    PSRemotingProtocolVersion 2.2

  5. #5
    Join Date
    May 2010
    Location
    Rochester, NY
    Posts
    51
    I have an older server that was running WFM 2014. This approach works on that server. On 2016 where I have to add port 81 into the URL, it fails with the unauthorized message. On both servers, IIS authentication at the Site level has both Forms and Windows authentication enabled. Anonymous authentication is disabled because we are using passthrough authentication with our AD credentials.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •