Hi! Sorry my english. I will try to explain our problem with InstallShield.
We need to reconfigure some accounts for security reasons. If we create an InstallShield setup with a full user (Admin) we have no problemas when running the installer. But if the same installer is created with a limited account we have NO ERRORS when creating the setup but we have the error 1628 when trying to install. The full error is: "Error 1628: Failed to complete script based install".
Looking the log files i have this:

LOG FROM INSTALLER CREATED WITH ADMIN ACCOUNT:

...
MSI (c) (20:B0) [08:58:40:889]: PROPERTY CHANGE: Adding ISSETUP_UISEQUENCE_PROCESSED property. Its value is '1'.
MSI (c) (20:B0) [08:58:40:889]: Note: 1: 2205 2: 3: Upgrade
MSI (c) (20:B0) [08:58:40:889]: Note: 1: 2228 2: 3: Upgrade 4: SELECT ActionProperty FROM Upgrade
InstallShield 08:58:40: Could not find setup.ini where expected (\\192.168.0.9\DiscoR\DISK1\). Defaulting to skin file setup.skn
InstallShield 08:58:40: Not using skins for this installation. Could not find skin file \\192.168.0.9\DiscoR\DISK1\setup.isn.
MSI (c) (20:B0) [08:58:40:970]: PROPERTY CHANGE: Adding ALLUSERS property. Its value is '1'.
MSI (c) (20:B0) [08:58:41:427]: Note: 1: 2205 2: 3: ReserveCost
MSI (c) (20:B0) [08:58:41:427]: Note: 1: 2228 2: 3: ReserveCost 4: SELECT Component_,ReserveFolder,ReserveLocal,ReserveSource FROM ReserveCost
MSI (c) (20:B0) [08:58:41:427]: Note: 1: 2205 2: 3: DuplicateFile
MSI (c) (20:B0) [08:58:41:427]: Note: 1: 2228 2: 3: DuplicateFile 4: SELECT Component_,File_,DestFolder FROM DuplicateFile
MSI (c) (20:B0) [08:58:41:438]: Note: 1: 2205 2: 3: ISRequiredFeature
MSI (c) (20:B0) [08:58:41:438]: Note: 1: 2228 2: 3: ISRequiredFeature 4: SELECT * FROM ISRequiredFeature WHERE RequiringFeature = 'ZLDCT'
MSI (c) (20:B0) [08:58:46:709]: Note: 1: 2205 2: 3: ISAlias
MSI (c) (20:B0) [08:58:46:709]: Note: 1: 2228 2: 3: ISAlias 4: SELECT * FROM ISAlias
InstallShield 08:58:46: Ready to launch __OnMsiMaintenance.
...

NOW THE SAME LOG BUT FROM THE INSTALLER CREATED WITH LIMITED ACCOUNT:
...
MSI (c) (50:C8) [08:54:42:137]: PROPERTY CHANGE: Adding ISSETUP_UISEQUENCE_PROCESSED property. Its value is '1'.
MSI (c) (50:C8) [08:54:42:137]: Note: 1: 2205 2: 3: Upgrade
MSI (c) (50:C8) [08:54:42:137]: Note: 1: 2228 2: 3: Upgrade 4: SELECT ActionProperty FROM Upgrade
InstallShield 08:54:42: Could not find setup.ini where expected (\\192.168.0.9\DiscoR\DISK1\). Defaulting to skin file setup.skn
InstallShield 08:54:42: Not using skins for this installation. Could not find skin file \\192.168.0.9\DiscoR\DISK1\setup.isn.
MSI (c) (50:C8) [08:54:42:204]: PROPERTY CHANGE: Adding ALLUSERS property. Its value is '1'.
MSI (c) (50:C8) [08:54:42:205]: Leaked MSIHANDLE (3) of type 790541 for thread 10696
MSI (c) (50:C8) [08:54:42:205]: Leaked MSIHANDLE (2) of type 790537 for thread 10696
=== Verbose logging stopped: 14/06/2016 08:54:42 ===

I think the problem is the ReserveCost table, but i don't know how to solve this problem or where i can start to look for.
Thanks for any help you can bring to us.