Community Forums
Results 1 to 3 of 3

Thread: java.lang.NullPointerException while uninstalling

  1. #1
    Join Date
    Sep 2014
    Posts
    5

    java.lang.NullPointerException while uninstalling

    Hi

    I am trying create a installer with Installanywhere 2013 which will install tomcat and deploy a java web application in it.
    When i try to uninstall, i am getting a error saying java.lang.NullPointerException (after splash screen).
    Attaching screen shorts.
    Can some one help me.
    Name:  1.jpg
Views: 135
Size:  26.3 KBName:  2.jpg
Views: 145
Size:  119.3 KB

    Thanks
    Pratap

  2. #2
    Join Date
    Jul 2015
    Posts
    10

    Unhappy NullPointerException while uninstalling

    Hi;

    I had a similar issue, it was a few missing images.
    A NullPointerException while trying to use the uninstaller is possibly because of a missing resource or image. Did you modify the iap_xml file manually, in a text editor ? If so, you may have modified paths or names that are not visible in the IA designer UI, so you will not be aware of them. If you modify the iap_xml file manually, make sure all the paths and names of resources and images are correct.

    I had a long thread with support about this. Flexera seems to have the "wishful thinking" approach to this kind of issue. They don't "support" modifying the iap_xml file manually...but then, they have to support people who get stuck because they don't catch this NPE. There are images and resources listed in the iap_xml file, but they just assume that this file can never be corrupted and will never be changed by anyone. If your IA designer is configured to fail on missing resources, this "fail fast" behavior does not apply to these "hidden" resources and images.

    Anyways.

    Hope it helps you or someone else.

  3. #3
    Join Date
    Sep 2014
    Posts
    5

    NullPointerException

    Hi igiguere,

    Thanks for the response. It was very helpful.

    Quote Originally Posted by igiguere View Post
    Hi;

    I had a similar issue, it was a few missing images.
    A NullPointerException while trying to use the uninstaller is possibly because of a missing resource or image. Did you modify the iap_xml file manually, in a text editor ? If so, you may have modified paths or names that are not visible in the IA designer UI, so you will not be aware of them. If you modify the iap_xml file manually, make sure all the paths and names of resources and images are correct.

    I had a long thread with support about this. Flexera seems to have the "wishful thinking" approach to this kind of issue. They don't "support" modifying the iap_xml file manually...but then, they have to support people who get stuck because they don't catch this NPE. There are images and resources listed in the iap_xml file, but they just assume that this file can never be corrupted and will never be changed by anyone. If your IA designer is configured to fail on missing resources, this "fail fast" behavior does not apply to these "hidden" resources and images.

    Anyways.

    Hope it helps you or someone else.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •