Community Forums
Results 1 to 3 of 3

Thread: SQL script isn't running in Maintenance Mode

  1. #1
    Join Date
    Jan 2016
    Posts
    2

    SQL script isn't running in Maintenance Mode

    Hi,

    It's been almost 4 month that i use InstallShield 2012 Spring. I always find a way to solve my problems. But this time i don't know what to do. I've look on forums all over the Internet but it didn't help.
    It's been 6 hours of debugging and i still can't find the problem about SQL scripts. It runs correctly on Install and Uninstall. When i choose the Repair Mode, all CA runs and stuff but SQL script don't even run at all and i don't get any error about it. I'm using BasicMSI.

    I took a look at the verbose log. This is some part of the log that i think it can have the problem :

    Code:
    1: Beginning SQL Server Costing Process... 
    1: Reading the SQL script data from ISSQLConnection table... 
    1: ISSQLRequirement table does not exist... 
    1: Finished SQL Server Costing Process..
    
    ...
    
    Action start 10:52:35: ISSQLServerInstall.
    ISSQLServerInstall: 
    Action ended 10:52:35: ISSQLServerInstall. Return value 1.
    
    ...
    
    MSI (s) (B8:8C) [10:52:39:499]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI5EA9.tmp, Entrypoint: ISSQLServerUninstall
    1: Processing the SQL connection 'SQLCONNECT'... 
    1: Determining if there is at least one SQL script scheduled to execute under the connection... 
    1: The SQL script 'SqlScript22.sql' is not scheduled to execute. Script Execution=RunOnInstall, Action=Uninstall, Component State=None, Schema= 
    1: The SQL script 'SqlScript30.sql' is not scheduled to execute. Script Execution=RunOnInstall or RunOnUninstall, Action=Uninstall, Component State=None, Schema= 
    1: The SQL script 'SqlScript5.sql' is not scheduled to execute. Script Execution=RunOnUninstall, Action=Uninstall, Component State=None, Schema=
    ... 
    1: No SQL scripts scheduled to execute under the connection...Skip. 
    1: Skip the SQL connection 'SQLCONNECT'. There is no script to execute under this connection. 
    
    ...
    
    MSI (s) (B8:F8) [10:52:44:437]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI71FA.tmp, Entrypoint: ISSQLServerInstall
    1: Processing the SQL connection 'SQLCONNECT'... 
    1: Determining if there is at least one SQL script scheduled to execute under the connection... 
    1: The SQL script 'SqlScript22.sql' is not scheduled to execute. Script Execution=RunOnInstall, Action=Install, Component State=None, Schema= 
    1: The SQL script 'SqlScript30.sql' is not scheduled to execute. Script Execution=RunOnInstall or RunOnUninstall, Action=Install, Component State=None, Schema= 
    1: The SQL script 'SqlScript5.sql' is not scheduled to execute. Script Execution=RunOnUninstall, Action=Install, Component State=None, Schema= 
    ...
    1: No SQL scripts scheduled to execute under the connection...Skip. 
    1: Skip the SQL connection 'SQLCONNECT'. There is no script to execute under this connection.
    Well, help will be very appreciated.
    Last edited by AlexSquirrel; 02-19-2016 at 11:52 AM.

  2. #2
    Join Date
    Jan 2016
    Posts
    2
    Does anybody had this problem before?

  3. #3
    Join Date
    Jul 2011
    Posts
    47
    Yes I have this problem as i am fixing up my installer to use SQL Server 2016.
    Did you get a solution or workaround?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •