Community Forums
Results 1 to 4 of 4

Thread: Installer shows Install button instead of Next button

  1. #1
    Join Date
    Aug 2012
    Posts
    87

    Installer shows Install button instead of Next button

    I have 2 types of installation New or Upgrade which is coming from radio button. i used to give inputs by clicking next button in diiferent panels on particular panel the first time Install button in showing instead of Next button. But after that if I clicked on the button it shows Next . But for the very first time it shows Install.Please provide the solution.

  2. #2
    Join Date
    Jul 2003
    Location
    Bedford, MA USA
    Posts
    121
    The "Install" button appears on the last panel before Install Actions are executed. Typically, that is the Install Summary panel but you can have it be something else. You may have other panels in your project after the "New or Upgrade" panel, but due to rules or a Jump action perhaps, at runtime your installer thinks there are no more panels to show before Install Actions are executed.

    -Jeff

  3. #3
    Join Date
    Mar 2016
    Posts
    2
    I had the same problem, and after so much of investigation and struggle finally i could able to resolve it. Here is the problem and its solution:

    In my case, i given an option to choose radio button between say option 'a' and option 'b'.
    And my intention was to show different pre-installation summary screens based on the option selected, so i kept two pre-installation summary screen panels. But, since then, i started getting the "Install" button instead of "Next". I was wondering where it could go wrong, then finally i tried to remove one pre-install summary panel and kept only single panel with some dynamic variable value display based on the selected option.

    My problem got resolved after that.

    Hope this helps in your case also.

  4. #4
    Join Date
    Jun 2002
    Location
    Detroit, MI
    Posts
    165
    Another way is to set up completely opposite rules.

    Let's say one panel displays when x=true
    another is displayed when x=false

    Instead of having rules like:
    x=false
    x=true

    for the respective panels, use this instead.

    x=false
    x!=false

    Whenever IA sees that, I get the install button when I want it. You have to let IA know there is no possible exception.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •