Community Forums
Page 1 of 2 12 LastLast
Results 1 to 5 of 7

Thread: Password is shown in log file

Hybrid View

  1. #1
    Join Date
    Dec 2015
    Location
    Toronto
    Posts
    2

    Password is shown in log file

    All,
    i have IA 2013.
    I added password variables to the list of variables to hide their values (Project tab->Variables->configure variables) and set option to be "exclude value only".
    Log is enabled and variable values still appear in XML under STDERR tag.

    How can i prevent those variables to appear there or at least with empty values?
    (encryption is not an option as it affects silent installation)

  2. #2
    Join Date
    Jul 2003
    Location
    North Kingstown, RI, USA
    Posts
    1,330
    I had a similar problem with a Suite project. I am not as familiar with IA, but if you have the capability to execute custom actions, then my solution may work.
    During install I performed my work with a temporary password that I did not care if it shows in the log file.
    Near the end of the install I executed my custom action, a C# action, that will change the password to the desired password.
    Regards,
    Dan Lee

    Release Engineer

  3. #3
    Join Date
    Oct 2017
    Posts
    1

    Thumbs up

    Quote Originally Posted by DLee65 View Post
    I had a similar problem with a Suite project. I am not as familiar with IA, but if you have the capability to execute phen375 customer reviews actions, then my solution may work.
    During install I performed my work with a temporary password that I did not care if it shows in the log file.
    Near the end of the install I executed my custom action, a C# action, that will change the password to the desired password.
    Thanks for your idea. It solved my problem.
    Last edited by hailley; Yesterday at 07:20 AM.

  4. #4
    Join Date
    Dec 2015
    Location
    Toronto
    Posts
    2
    Thank you for suggestion, but this does not help me.
    I have log prints during pre-installation process ("Output debug information" action). And variables ARE printed to log files DESPITE listening them in variables configuration section that promises not to print their values in log file.
    Looks like a bug in IA

  5. #5
    Join Date
    Apr 2016
    Posts
    1
    Quote Originally Posted by arotbart View Post
    Thank you for suggestion, but this does not help me.
    I have log prints during pre-installation process ("Output debug information" action). And variables ARE printed to log files DESPITE listening them in variables configuration section that promises not to print their values in log file.
    Looks like a crazy bulk review bug in the IA
    Yes, same here and it worries me having passwords printed in the log files. I'm sure this can't be safe. Is this just a bug or is there a way to fix this. Maybe you found a way arotbart?
    Last edited by Liddles; 09-02-2016 at 11:26 AM.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •