Community Forums
Page 1 of 2 12 LastLast
Results 1 to 5 of 9

Thread: Error 1316: The specified account already exists.

  1. #1
    Join Date
    Apr 2015

    Error 1316: The specified account already exists.

    I am getting this error while upgrading the previous version of my application

    In other words when previous version is already installed in the target machine and when newer version is tried to install up on that then this error is popping up which in turn rollbacks to previous version

    plz suggest how to get rid of this error.

  2. #2
    Join Date
    Mar 2015
    Fargo, ND

    I'm also seeing this error for an upgrade.

    Any help would be appreciated.

  3. #3
    Join Date
    Oct 2010
    We have a customer report of this same problem but can't reproduce it. In our case, the customer said they tried to uninstall the original version first. It failed for some reason but the product disappeared from the Control Panel list of programs. They then installed the update which triggered this error but installed successfully. However, it doesn't appear on the Control Panel list of programs, so we're not sure how it can be uninstalled. Would like to have a clean uninstall to reset the user's machine. We haven't had reports of this from other customers. Any insight or solution would be appreciated. Thanks.

  4. #4
    Join Date
    Oct 2011
    I got the same error message, but in my case when I looked into the install log, it failed at RegisterProduct action and I figured out that I've been renamed our product name to a new trademark (from (R) to (TM)) and caused this error during upgrade.

    You can do the same by looking into your install log and see where it throws this error.


  5. #5
    Join Date
    Jan 2015
    hi all,

    I too faced the same issue and solved by rerun the same version installer. important thing is you have to rerun the exact version of the installer i mean packaging code( GUID may or may not be same)) should be the same.

    in my case we have designed our installer to go to maintenance mode if i try to install my product on a host where same version(same package code but GUID may or may not be same) product is already installed. I Install the product once again by choosing modify option. once installation is completed I will have choice to uninstall the product from add/remove programs or by using GUID.

    if your are not designed your installer to go to maintenance mode, then simply install the same version product (same package code but GUID may or may not be same). on a host where your seeing the issue and then uninstall.

    1. when you are ended up in this situation mostly you dont see installed files some times add/remove programs entries too, so find out what version you have installed by looking at stale entries from registry under
    HKEY_LOCAL_MACHINE\SOFTWARE\your product name

    if your product is 32 bit and installed on 64 bit machine check here HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\your product name

    you can get more detials HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

    hope your issue will be resolved.


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts