Community Forums
Results 1 to 5 of 5

Thread: IISRT -1208 error

  1. #1
    Join Date
    Jul 2012
    Posts
    1

    IISRT -1208 error

    Hello,
    I'm trying to track down the problem with this error. I'm trying to install to the Default Web Site some virtual folders/applications. I install the files/folders to the inetpub/wwwroot folder.
    The error always stops the installer with this:
    Action 17:36:10: ISIISCosting.
    Action start 17:36:10: ISIISCosting.
    Action 17:36:10: Progress Custom Action. Extracting information for IIS virtual directories...
    InstallShield 17:36:10: Error with IISRT: -1208
    CustomAction ISIISCosting returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    Action ended 17:36:10: ISIISCosting. Return value 3.
    Action ended 17:36:10: INSTALL. Return value 3.

    I thought maybe it was because the files hadn't been moved yet so I moved IISCosting after InstallFiles in the Custom Actions and Sequences.
    Any help would be appreciated!

  2. #2
    joshstechnij's Avatar
    joshstechnij is offline InstallShield Software Engineer
    Join Date
    Jul 2006
    Location
    Schaumburg, IL
    Posts
    1,763
    This error indicates that there is an empty executable path for an application mapping on a website, application, or virtual directory that is included in the project. This value cannot be empty. Note that the IDE will not allow an application mapping to be added that does not contain an executable path. To verify that an application mapping is present in the project with an empty executable path, go to the IIS view and look at all application mappings present for any websites, applications, or virtual directories that are listed in the view. Either remove or correct any mappings that do not have a value for executable path.

    Also note that if the executable path is a property reference ([PROPNAME]) and this property has no value at runtime, the executable path will resolve to an empty value which will also cause this error. If a property is used for the executable path in an application mapping, the property referenced needs to contain a value to avoid this error.
    Josh Stechnij - Software Engineer - Flexera Software: InstallShield Team

  3. #3
    Join Date
    Apr 2014
    Posts
    5

    IISRT -1208 Error

    I am having the same issue as the original poster.

    I think I found the entry in the Application Mappings with the missing Executable Path. However, as the entirety of the IIS information was captured with IISscan and imported into InstallShield, I am tending to believe that IISscan may have a bug. Could this be investigated? I can attach any project information you may need.

    Further, since I can see the entry with the bad mapping, do you know a way to identify what the source was for this value? I mean, if the entry is correct in IIS, I need to figure out what the value should be and update in the project, or if it's not correct in IIS, I'll need to determine where in IIS it is so IIS can be fixed.

    At this point, I don't know how to proceed: a) Remove the entry with the bad mapping from the IS project, or b) Dig into IIS to try and find an mapping with no path, or c) Wait for a bug in IISscan to be corrected. Please advise the best route.

    Thank you.

  4. #4
    joshstechnij's Avatar
    joshstechnij is offline InstallShield Software Engineer
    Join Date
    Jul 2006
    Location
    Schaumburg, IL
    Posts
    1,763
    Assuming you are working on an IIS7.x or newer machine, the application mappings are captured from the system.webServer/handlers collection in applicationHost.config (the collection is tied to a virtual root/application through a 'location' element). The application mappings are available in more readable format through the Handler Mappings for a given website, virtual directory, or application in IIS Manager.

    In order to determine whether there was an issue with the IIS scanner, we would need to know what the original data was associated with a website that was scanned. If you can provide a list of the handler mapping information from the website that was scanned that may help to isolate the behavior.
    Josh Stechnij - Software Engineer - Flexera Software: InstallShield Team

  5. #5
    Join Date
    Apr 2007
    Posts
    3

    OK, I'm having the same problem with the results of IIsscan

    Used IISscan as well on a Default Web Site ...See attachment?
    Attached Files Attached Files

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •