Community Forums
Results 1 to 5 of 5

Thread: Graphical installers are not supported by the VM

  1. #1
    Join Date
    Nov 2011
    Posts
    5

    Graphical installers are not supported by the VM

    Hi Experts,

    Version: InstallAnyWhere 2010 SP1
    OS : Red Hat Enterprise Linux Server release 6.4 (Santiago)

    During start-up of install.bin in some of the Linux machines we were facing issue like, "Graphical installers are not supported by the VM" and it is throwing following error,

    Preparing to install...
    Extracting the JRE from the installer archive...
    Unpacking the JRE...
    Extracting the installation resources from the installer archive...
    Configuring the installer for this system's environment...

    Launching installer...

    Graphical installers are not supported by the VM. The console mode will be used instead...

    =======================================================

    Installer User Interface Mode Not Supported

    The installer cannot run in this UI mode. To specify the interface mode, use the -i command-line option, followed by the UI mode identifier. The valid UI modes identifiers are GUI, Console, and Silent.

    =======================================================

    I try to debug the issue using sh -i install.bin and found that only one error in the log ie, "chooseBundledVMs: unable to locate the vmpack directory". Please refer attached console error log for more details.

    Am not able to find out exact root cause of the problem. Any idea what might be wrong here?

    Thanks,
    Mohan
    Attached Files Attached Files

  2. #2
    Join Date
    Mar 2006
    Location
    Paris, France
    Posts
    2,147

    Exclamation

    This error usually means that some X graphical libraries are missing from the target system.
    Vlad

  3. #3
    Join Date
    Nov 2011
    Posts
    5
    Thanks Vlad. can you pls list out the required X graphical libraries.

    Thanks,
    Mohan

  4. #4
    Join Date
    Jan 2013
    Posts
    4
    I am also facing the same issue on the Linux system( Red hat 6.6 Santiago). Please advise what kind of the graphical libraries are missing from the system.

    Thanks,
    Ratnesh

  5. #5
    Join Date
    Jan 2015
    Posts
    33
    Quote Originally Posted by pv7721 View Post
    This error usually means that some X graphical libraries are missing from the target system.


    I am also facing the same issue bu on RHEL 7.3 packages ia created with IA2017, could you please help me Vlad.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •