Community Forums
Results 1 to 2 of 2

Thread: Failed to load ISWIBuild: -2147221164

  1. #1
    Join Date
    Oct 2013
    Posts
    1

    Failed to load ISWIBuild: -2147221164

    I have created installshield projects in VS2010 and can successfully create MSIs locally without any issues.
    I created a build definition in Team Explorer (TFS) and getting the following error on triggering this build:

    C:\Program Files (x86)\MSBuild\InstallShield\2012SpringLimited\InstallShield.targets (96): Failed to load ISWIBuild: -2147221164

    I am using installshield Spring limited edition. I do not see ISWIBuild.dll under
    C:\Program Files (x86)\MSBuild\InstallShield\2012SpringLimited folder.

    I found 'ISWIBuild.dll' on this forum and copied this dll to
    C:\Program Files (x86)\MSBuild\InstallShield\2012SpringLimited folder.
    But still getting 'Failed to load ISWIBuild: -2147221164' error.

    Please let me know how to fix this issue?


    Thanks
    Jaspal

  2. #2
    Join Date
    Nov 2013
    Posts
    1

    Experience the same issue

    We facing the same issue in our production environment. We think that its happen bacause of we have two separate ISLE project in one Vistual Studio 2010 solution and we try build it by TFS 2010 autobuild mechanismus (like is describe in this thread: http://community.flexerasoftware.com...ild-2147221164). There is also mention workaround but we have problem to understand exactly solution. We still fighting with that...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •