Community Forums
Page 2 of 3 FirstFirst 123 LastLast
Results 6 to 10 of 12

Thread: InstallScript Setup Launcher Unicode Has Stopped Working (Windows message)

  1. #6
    Join Date
    Nov 2007
    Posts
    63

    Cool

    Hi!

    Last week a colleague of mine had the infamous "InstallScript Setup Launcher Unicode Has Stopped Working" error again. I tried to assist him by checking the said folders and we ended up creating a new admin, but this time this did not help either. I told him that there is nothing I could do at this point and we decided to use an old version of our product that was still built with IS2012 (I have to wait until next year before budget allows me to buy IS2014).

    Today my colleague called me that he was able to install the new version of the software because he found out which folder was actually missing! He was using Microsoft's Process Monitor from Sysinternals to inspect the Setup.exe's file access and there it was amongst a huge pile of successfull folder checks there was one that failed due to a missing folder... Created missing folder => Setup runs! Atta boy!
    That might not be a complete solution but at least a work around for the desparate ones.

    Cheers!

    Ralf

  2. #7
    Join Date
    Apr 2015
    Posts
    1

    The fix for Windows 8 and Windows Server 2012 and up

    Quote Originally Posted by DaveSimmons View Post
    Update:

    We've been working with Flexera on this and it appears to be a crash bug in the IS2013 startup code. triggered when one or more standard Windows folders are missing from the customer's PC:

    1. C: > Users > ("Yourname" Windows account ) > My Documents
    2. C: > Users > ("Yourname" Windows account ) > AppData > Local
    3. C: > Users > ("Yourname" Windows account ) > AppData > Roaming > Microsoft > Windows > Start Menu > Programs > Startup
    4. C: > Users > Default > Documents
    5. C: > Users > Default > AppData > Roaming > Microsoft > Windows > Start Menu > Programs > Startup

    Workarounds include having the customer manually create the folder(s), or using one of your older IS2011 installs then some non-IS patching or update scheme if you have one.

    We've provided Flexera with setup log traces and with customer confirmations of the manual fix so it seems likely they should be able to release a fix for this.
    The info above only works on Windows 7 and below.
    I found nothing else on how to fix it for Windows 8 / Server 2012 so I updated on my blog.
    http://brian-kayser.blogspot.com/201...-launcher.html

  3. #8
    Join Date
    Jul 2015
    Posts
    1

    InstallScript Setup Launcher Unicode Has Stopped Working (Windows message)

    I still see the same error in Install shield 2014 as well. Any idea what to do?

  4. #9
    Join Date
    Nov 2002
    Location
    Boulder, Colorado
    Posts
    198
    Well it looks like I'm now involved in this bug. We just upgraded to Installshield 2014 from 2012 Spring. It happens all the time even if you "Run as Administrator". I double checked that those folders were there as suggested in the earlier posts. Is there any resolution on this?

  5. #10
    Join Date
    Apr 2013
    Posts
    2

    Not working on Server 2012 R2

    Just adding my 2 cents to this thread. We upgraded from IS2012 spring to IS2013 because it supported Windows 8.1 and Server2012R2.

    We have Software-As-A-Service on Amazon Cloud instances. Most of our clients use English. We have no trouble installing to those cloud instances. But the Chinese customer is producing this error message, even though we set the regional setting for that computer to English before attempting to install. These cloud instances are all Server 2012R2.

    Additional information:
    The instances are not new. We uninstalled our previous version before attempting to upgrade. We ran the setup.exe as an administrator. The username used was the administrator of that instance.

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •