Community Forums
Results 1 to 4 of 4

Thread: IISRT (ISIISInstall) Error -2147024891 (0x80070005, AccessDenied)

  1. #1
    Join Date
    Nov 2004
    Posts
    11

    IISRT (ISIISInstall) Error -2147024891 (0x80070005, AccessDenied)

    Using InstallSheild 2012SP1, I am trying to install a website ("cloud") using IS's IIS Custom action (ISIISInstall) on Win 2008 R2 SP1.

    App Pool creation works fine and the initial site setup appears to go well. Below is where the error(s) show up in the logs.

    Any ideas what ISIISInstall is doing at this point so I can determine why I'm getting Access Denied?

    NOTE: I removed the timestamps the the MSIHANDLE entries...
    Code:
    --SNIP-- app pool setup, and site creation and ssl cert insertion all appear to succeed -- 
    
    SetCommonProperties for the following: cloud
    SetVRtDWProperty for property '6016' with value '513'.
    GetAdminSection for section 'system.webServer/handlers' and path 'MACHINE/WEBROOT/APPHOST/cloud' and commitpath 'MACHINE/WEBROOT/APPHOST/cloud'.
    PutPropertyValue: sProperty accessPolicy sValue Script, Read bIsPath 0
    PutPropertyCommon: sProperty accessPolicy sValue Script, Read bIsPath 0
    getvaluelog
    getvaluelog
    Setting property 'accessPolicy' to value 'Script, Read' for element 'system.webServer/handlers'. Old value: '513'. m_sSectionName : 'system.webServer/handlers'.
    getvaluelog
    put_value succeeded. get_StringValue now returns '0' with string value 'Read, Script'.
    CommitChanges for path 'MACHINE/WEBROOT/APPHOST/cloud' and physical path 'C:\Program Files\MyStuff\Sites\Cloud\'.
    CommitChanges failed with the following HRESULT: '-2147024891'. Per the next line, I assume this can be ignored.
    put_Value determined that property is not actually changing, so ignore CommitChanges failure.
    Changing CommitPath from 'MACHINE/WEBROOT/APPHOST' to the following: MACHINE/WEBROOT/APPHOST/cloud
    SetVRtDWProperty for property '6005' with value '0'.
    GetAdminSection for section 'system.webServer/directoryBrowse' and path 'MACHINE/WEBROOT/APPHOST/cloud' and commitpath 'MACHINE/WEBROOT/APPHOST/cloud'.
    PutPropertyValue: sProperty enabled sValue false bIsPath 0
    PutPropertyCommon: sProperty enabled sValue false bIsPath 0
    getvaluelog
    getvaluelog
    Setting property 'enabled' to value 'false' for element 'system.webServer/directoryBrowse'. Old value: '-1'. m_sSectionName : 'system.webServer/directoryBrowse'.
    getvaluelog
    put_value succeeded. get_StringValue now returns '0' with string value 'false'.
    CommitChanges for path 'MACHINE/WEBROOT/APPHOST/cloud' and physical path 'C:\Program Files\MyStuff\Sites\Cloud\'.
    CommitChanges failed with the following HRESULT: '-2147024891'. <---- ******************* 0x80070005 (E_ACCESSDENIED)
    Error with IISRT: -2147024891

  2. #2
    Join Date
    Oct 2010
    Posts
    219
    Usually this happens when your web.config is set to read only....
    may be you can check that...
    Cheers!

  3. #3
    Join Date
    Nov 2004
    Posts
    11
    Correct. It seems the web.config is read-only when it is checked out of source control for the build. Whereas app.configs are compiled into App.exe.config so they are NOT read-only during install as they are generated items (not directly checked-out from source control). This explains why I'm able to edit app.exe.config without issue during the install.

    I was able to change the web.config's read-only setting by selecting the file's properties within my cloud_root_files component and then overriding the read-only option by clearing the "read-only" checkbox. See included pictures.

    Name:  ComponentFileProperties.png
Views: 1179
Size:  12.2 KBName:  WebConfigOverride.png
Views: 1176
Size:  15.8 KB

  4. #4
    Join Date
    Apr 2009
    Posts
    4

    Problem with TCP/IP Port

    I encountered a similar problem. "CommitChanges failed with the following HRESULT: '-2147024893'. The system cannot find the path specified. "
    It was later found out that we did not have a matching TCP/IP portnumber. The default port number 80 was changed to 70 in the "IIS Default Website".

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •