Community Forums
Results 1 to 3 of 3

Thread: How to include .NET Framework in setup

  1. #1
    Join Date
    Oct 2011
    Posts
    6

    How to include .NET Framework in setup

    Using InstallShield 2012 Express (ver 18), I want to include the .NET Framework 4.0 Full redistributable, for it to siimply install from the source location (a LAN location in this case) to the target machine -- if it doesn't already have that installed. But I do not want it to be having to download it from the Internet.

    So, within Step 2 "Specify Application Data", under "Redistributables", I have "Microsoft .NET Framework 4.0 Full" checked. And the location is "Installed Locally". I saw that IS did a download when I selected that.

    Is this the correct way to specify this?

    When I did a test-install, the installer seemed to be downloading the framework from the Internet (which is a large 50MB download) instead of just copying it over from the installer location. Why is this? What am I doing wrong?

    Thank you for your help,

    James Hurst

  2. #2
    Join Date
    Oct 2001
    Location
    Itasca, IL
    Posts
    2,396
    Please make sure that you select the Extract From Setup.exe or Copy From Source Media option for the InstallShield Prerequisites Location setting in the Setup.exe tab of the Releases view. If the Follow Individual Selections option is selected, make sure that the Download From the Web option is not selected for the Build Location setting on the InstallShield Prerequisite Properties dialog in the Redistributables view. To launch the InstallShield Prerequisite Properties dialog, right-click on the Microsoft .NET Framework 4.0 Full prerequisite and select the Properties menu option.
    Hidenori Yamanishi - Senior Software Engineer - Flexera Software: InstallShield Team

  3. #3
    Join Date
    Sep 2017
    Posts
    2

    InstallShield 2015 Limited edition, how to include .Net framework 4.5 to MSI not exe

    Hi,
    I want to include the .Net framework and create the setup package as .msi and not setup.exe.

    I have created setup package using below link

    https://msdn.microsoft.com/en-us/lib...v=vs.120).aspx

    Selecting prerequisite on Application Data (Step 2) => Redistributables also throwing error for .msi (no error for setup.exe but the requirement is msi package)

    Please guide me on this.

    Thanks in Advance..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •