Community Forums
Results 1 to 4 of 4

Thread: Error 1155: Cannot find [PRODUCT NAME].msi

  1. #1
    Join Date
    Aug 2008
    Posts
    3

    Error 1155: Cannot find [PRODUCT NAME].msi

    InstallShield 2009 SP1

    I'm using a Basic MSI project set to release into a single Setup executable. This runs fine on XP/Vista 32-bit, but on Windows Vista Ultimate x64 Edition it errors: I get a 1155 [Temp folder]\[GUID]\[Product Name].msi File not found error.

    If I navigate to that directory in Explorer before clicking OK to the error dialog, the .msi file is there, and running it installs the application as expected.

    I've tried running setup.exe with the /debuglog parameter to see what's happening - but it installs fine and does not error

    Would I be correct that assuming this is some-kind of bug with InstallShield or is there a simple workaround?

    Any suggestions are gratefully received.

    Kindest regards,

    Tim

  2. #2
    Join Date
    Aug 2008
    Posts
    3

    Character Set?

    UPDATE

    Not sure how I missed it last time, but I think I've found the cause of the error - At the beginning of the [product name].msi in the Temp folder there is a strange character (similar to รณ). Could this be an ANSI/Unicode discrepancy.

    Any suggestions welcome.

  3. #3
    Join Date
    Oct 2001
    Location
    Here and there
    Posts
    16,243
    Please see if this thread is related.

  4. #4
    Join Date
    Aug 2008
    Posts
    3
    Thanks - that thread describes the exact same issue - solution has worked fine.

    Apologies for the double-post.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •