Community Forums
Results 1 to 2 of 2

Thread: Installer 4.5

  1. #1
    Join Date
    Jul 2006
    Posts
    47

    Installer 4.5

    I know about the installer 4.5 prerequisite, but is it just enough to include that in the project?

    In the setup.exe tab there is the choice of installer to use which seems to have absolutely nothing to do with 4.5, so how do I know that I am using 4.5 and not 2.0 or whatever the Setup.exe tab in the release is set to?

    How do I get it to use only the 4.5 instaler and not waste bytes including an older installer that I don't want?

  2. #2
    Join Date
    Jan 2004
    Posts
    2,074
    If you don't want to include Windows Installer 3.x or earlier in your project, but you do want to include Windows Installer 4.5:

    • On the Setup.exe tab in the Releases view, select Yes (no MSI engine included) for the Setup Launcher setting. (A setup launcher must be used if you're using prerequisites in an installation.)
    • In the Redistributables view, add the appropriate Windows Installer 4.5 prerequisites. Depending on which operating systems you are targeting, you may need to include more than one prerequisite.

    The following help topic indicates which operating systems are supported by each prerequisite:
    Including Microsoft Windows Installer Prerequisites

    Note that Windows Installer 4.5 cannot be installed on some systems. For example, it can't be installed on Windows 2000, 32-bit Windows XP (RTM release), or 32-bit Windows XP SP1. If it should be possible for your product to be installed on these platforms, be aware that Windows Installer 4.5 will not be present and cannot be installed. If your installation uses Windows Installer 4.5 functionality, the behavior will be different on these systems. For example, if you are using the new multiple-package installation using transaction processing feature, systems that have Windows Installer 3.1 or earlier will not launch the chained .msi packages.

    Debbie Landers
    Acresso Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •