Community Forums
Results 1 to 5 of 5

Thread: Vista "The installer cannot run on your configuration. It will now quit."

  1. #1
    Join Date
    Mar 2008
    Posts
    7

    Vista "The installer cannot run on your configuration. It will now quit."

    Our installer is built on Windows XP and runs fine on that platform.

    When running the installer executable on Vista however, we get the error

    "The installer cannot run on your configuration. It will now quit."

    Changing the compatibility mode to XP resolves it, but is there a way to have it built natively for Vista without having to do that manual change every time it gets built

  2. #2
    Join Date
    Mar 2008
    Posts
    7
    This is with Installer Anywhere Enterprise Value Pack 1

  3. #3
    Join Date
    Mar 2006
    Location
    Paris, France
    Posts
    2,147

    Question

    Do you have a rule that allows the installer to run on Vista? If you have a rule that allows your installer to run only on XP, changing the compatibility mode in Vista to XP will make the installer thinks it's running on XP, this is why it works.

  4. #4
    Join Date
    Mar 2008
    Posts
    7
    Thanks, I added Vista under Projects->Rules and the error is gone.

  5. #5
    Join Date
    Jan 2018
    Posts
    2
    I have this exact same issue on IA 15 and IA 17. Any solutions found around this?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •