Community Forums
Page 1 of 2 12 LastLast
Results 1 to 5 of 9

Thread: Costum actions are called at the wrong time

  1. #1
    Join Date
    Jul 2003
    Location
    Netherlands
    Posts
    14

    Thumbs down Custom actions are called at the wrong time


    I want to call my DLL 'After File Transfer'
    The DLL relies on a file that is copied to the system32 folder.
    When the DLL is called, no files are in place at all!! I checked this by adding a MsgBox call from within my DLL routine.
    When the message is displayed, nu files have been copied to the target folders at all.
    When moving my Custom action to 'After setup complete success dialog' it works fine, BUT the action takes place after the installation was informed to be complete to the user.

    What am I missing here?

    Anyone? I have no support contract, does this mean that reporting a serious bug does not even allow Macrovision to send some response by email or this forum? This is not what I expect!

    Hello! it's a BUG. when I buy a car, I don't need a support contract if something does not work as it should, well within the guarantee period.

    I am getting a bit angry now, not taken seriously.

    Maybe Macrovision does not look in this forum at all? ever?

    Hans
    Last edited by h.hasenack; 02-23-2007 at 10:49 AM. Reason: Pure annoyance.

  2. #2
    Join Date
    Feb 2007
    Posts
    3

    DLL called at wrong time

    I have a similar problem:

    I want to call my dll after registering product. It is called before copying files. Obviously the dll was copied as part of the product.

    To comment on Macrovision support:
    Macrovision works from what they call a support plan. If you don't have a support plan, you cannot get support. It is far from obvious that this doesn't mean: Macrovision has your money and that you have to pay to get Macrovision bugs fixed.

    It is supposed to work as follows: You buy a per incident support plan ($100). You file your case under that plan. Macrovision figures, just like we did, that the reported case is a bug in InstallShield. Macrovsion gives you your money back and a fix when the fix becomes available.

    Jos

  3. #3
    Join Date
    Jul 2003
    Location
    Netherlands
    Posts
    14

    Someone is looking at it now.

    Well, after some communication with the sales dept, I got the advise to download Installshield Pro and evaluate that one.

    As it turns out, with the pro download I got some kind of support access, and I was able to post my bug as a support request.


    The problem was
    1) I had to by a support plan when buying the software, I couldn't do it afterwards
    2) It's a bit strange to pay at forehand in order to get help. a Bit like "No Cure, money gone, you try to get it back". In a garage or, you'd get the bill afterwards.
    3) I also find it strange that I can get support before buying the product, but that is tedious afterwards!

  4. #4
    Join Date
    Mar 2006
    Location
    Wisconsin
    Posts
    41

    Macrovision Poor Response

    I keep hearing things have been fixed in service pack 1 for Premier and Professional. But not Express.

    When is the service pack 1 for Express coming. I have had this question out there for a week, and Macrovision will not respond.

    Quote Originally Posted by h.hasenack View Post

    I want to call my DLL 'After File Transfer'
    The DLL relies on a file that is copied to the system32 folder.
    When the DLL is called, no files are in place at all!! I checked this by adding a MsgBox call from within my DLL routine.
    When the message is displayed, nu files have been copied to the target folders at all.
    When moving my Custom action to 'After setup complete success dialog' it works fine, BUT the action takes place after the installation was informed to be complete to the user.

    What am I missing here?

    Anyone? I have no support contract, does this mean that reporting a serious bug does not even allow Macrovision to send some response by email or this forum? This is not what I expect!

    Hello! it's a BUG. when I buy a car, I don't need a support contract if something does not work as it should, well within the guarantee period.

    I am getting a bit angry now, not taken seriously.

    Maybe Macrovision does not look in this forum at all? ever?

    Hans

  5. #5
    Join Date
    Jul 2003
    Location
    Netherlands
    Posts
    14

    Unhappy Support incident

    Yeah...

    Actually macrovision support confirmed it is a bug now. Without me actually buying a 'support incident' because I made a lot of noise at the sales dept.

    They told me next time "I Really have to by a soppurt incident ($250) first. "
    That's Right: a support incident is only 50% of the product price

    I think not. Next time I'll probably switch to a company offering support within the warranty period of the software. Strangely though, you do get support when using an evaluation copy, but when you buy the product, the support is gone...


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •