Community Forums
Results 1 to 4 of 4

Thread: Unable to Install Framework 2.0 from setup.exe

  1. #1
    Join Date
    Feb 2007
    Posts
    4

    Exclamation Unable to Install Framework 2.0 from setup.exe

    I am trying to create a simple installation project for a simple .net application. I have had zero success at getting the installation to install Framework 2.0 on a machine with no Framework version previously installed.

    I have been able to do this when getting the Framwork downloaded from the web, however this app will be installed on machines that don't have access to the web.


    I have the following settings:
    MSI Engine Version: Version 3.1 or 2.0 (best fit for system)
    MSI Engine Location: Evtract Engine From Setup.exe
    Include Setup.exe: Yes
    Include MSI Engine(s): Both 9x and NT Engines
    .NET Framework Location: Extract From Setup.exe
    .NET Framework Version: .NET 2.0


    When run, I get the following error messages:
    "Windows cannot find 'C:\DOCUME~1\James\LOCALS~1\Temp\{EC710CC6-DC3F-4F60-A78E-AC8F420A8A13}\1033dotnetredist.exe'"
    and
    "1155: Error installing Microsoft(R).NET Framework. File %s not found."

    Any help or suggestions appreciated.
    Last edited by JamesJay; 02-12-2007 at 12:07 PM.

  2. #2
    Join Date
    Feb 2007
    Posts
    4

    Angry I have found the problem installing Frameworks 2.0

    I understand that Vista has a new framework version, 3.0. That being the case, I would think that the copy of InstallShield Express that I bought last month would have the files necessary to install Framework version 2.0. That, pathetically, is not the case.

    I rebuilt my installation to install .NET Framework Version .NET 1.1 and the installation ran perfectly. Of course, my app won't execute because it's looking for version 2.0.

    I'm going on a hunt now to see if I can find the correct file to download but I would really appreciate it if any IS people reading this can get back to me quickly with the correct file.

  3. #3
    Join Date
    Feb 2007
    Posts
    4

    Thinking about it

    I don't suppose I could get a discount on the purchase price, seeing as you gave me an obsolete product?

  4. #4
    Join Date
    Feb 2007
    Posts
    4

    Angry Got it! (With no help from IS)

    OK, it's working. Here's how.
    After looking around Macrovision Community, Google Groups, etc. for an answer I decided to reinstall IS Express. I put in the CD. It asked if I wanted to save the setup.exe to my hard drive. I said yes but then the setup.exe copied to my hard drive failed. Figures.

    I opened the CD for browsing. I started to double click setup.exe on D:\Installs when I noticed a dotnetfx20.exe in the folder. I compared it to the dotnetfx20.exe in the C:\Program Files\Macrovision\IS12 Express\Redist\0409\i386 and saw that they were different sizes. I copied the file from D:\Installs to the C:\... path and the installed worked.

    I'll repeat my request for a partial refund for the purchase price of this product. I shouldn't have to fix your software without compensation. I have a difficult enough time fixing my own software. Not a happy customer of Macrovision.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •