Community Forums
Results 1 to 3 of 3

Thread: Problem with custom bean..

  1. #1
    Join Date
    Nov 2006
    Posts
    6

    Unhappy Problem with custom bean..

    Hi,

    I have a problem registering custom bean...

    I have created a custom bean which adheres to all the Java beans rules and it extends WizardAction and also I have put the class files in the <Installshield home>/classes folder. But when I try to registry the bean, it say "Please specify a valid bean name". Actually the same custom bean was working sometimes before, but suddenly it's not working. So when I click the custom bean in the sequence I'm getting the following error :

    Custom bean information

    The following occurred while attempting to load this bean from your project file:

    The wizard bean "ver5_1_serv1_disablebean" could not be loaded because the
    following exception occurred: com.jxml.quick.QPE:
    java.lang.ClassNotFoundException: WindowsServiceChangeStartupTypeBean

    Information will not be lost if you save your project, but you must resolve this issue
    before you can successfully build your project.

    Note: If you are loading a project converted from InstallShield Java Edition 3.x, you
    must convert and recompile your custom beans and register them in Universal. For
    additional information on converting InstallShield Java Edition 3 custom beans, refer
    to

    Migrating InstallShield Java Edition 3.x Projects, please refer to the User's Guide

    Please tell me how to correct this problem and I got stuck up here...

    Thanks...

  2. #2
    Join Date
    Nov 2006
    Posts
    6

    resolved..

    Theproblem is compile the bean with java 1.5 and installshield uses 1.4, that's the problem. got it resolved.

  3. #3
    Join Date
    Sep 2015
    Posts
    1
    I am trying to use ISMP 11.5 and it was working fine for a long time. This week, I saw this error showing up in ISMP 11.5 project (.uip) for every function inside the file.
    I see that jdk1.5 is present in the ISMP folder. I tried to get jdk1.4 but it cannot be installed because of incompatibility with the processor.
    I think it is too old to use ISMP now. But I don't understand how it worked find for a long time and it showed this error just few days back.
    Can it be because of a system update ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •