Community Forums
Results 1 to 5 of 5

Thread: Standalone build error -6645?

  1. #1
    Join Date
    Jan 2006
    Posts
    17

    Standalone build error -6645?

    Greetings

    I did a search of the forums but didn't see this problem addressed, so...

    When I first obtained InstallShield 11 Professional, I configured the standalone build for my project and all was well. Sometime after updating to InstallShield 11.5 Professional, I started to have build problems. A recent update to 11.5 Premier didn't fix them, so I'll ask...

    I receive errors like the following:

    ISDEV : error -6645: C:\build\FlowLink\Installshield\11\FL Server Files for InstallShield\sqlite.dll failed to load.
    Error: 0
    Error Description:
    ISDEV : error -6645: C:\WINDOWS\system32\kernel32.dll failed to load.
    Error: 0
    Error Description:
    ISDEV : error -6645: C:\WINDOWS\system32\kernel32.dll failed to load.
    Error: 0
    Error Description:
    ISDEV : error -6645: C:\Build\FlowLink\bin\pesgo32c.ocx failed to load.
    Error: 0

    In this example, sqlite.dll and pesgo32c.ocx are files in my project, but kernel32.dll obviously isn't. The resulting image builds, but with these errors (and yes, the kernel32.dll error is repeated one after another, as shown above).

    If I build using the IDE, I do not receive these errors - the images build without problem.

    What could cause these errors in the standalone build when the IDE build doesn't have them, with all other project files being the same? What actually is this error, as it does not have a description?

    The version of the standalone build engine is 11.50.0.42618, which the IS updater seems to identify is the most current.

    Thanks!

    Charles

  2. #2
    Join Date
    Oct 2001
    Location
    Here and there
    Posts
    16,243
    Perhaps see if KB article Q112146, "HOTFIX: Build Error -6645 Occurs When Including .NET Application File in Project", at http://support.installshield.com, applies?

  3. #3
    Join Date
    Jan 2006
    Posts
    17
    Thanks! That did it. Interesting that the error is caused by the .NET 2.0 framework, though the assemblies in my project are still .NET 1.1.

    C.

  4. #4
    Join Date
    Mar 2005
    Location
    Sheffield, England
    Posts
    20
    Is this hotfix available for installshield 10.5 stand alone build?

  5. #5
    Join Date
    Sep 2006
    Posts
    38
    RobertDickau,

    I am extremely new at this, and am trying to understand your remarks. In the hotfix link it says:

    "Resolution
    This will be permanently resolved in InstallShield 12 and above. The solution is simply to suppress this error message, as it should not be displayed and will not negatively impact the built setup."

    Does suppress mean simply to ignore this error? Will the build be ok when completed if this error exists?

    I've scoured every entry on these forums for a solution that works for me, but have had no success using InstallShield 11.0.

    The error occurs on a file not in the Windows System folder for me.

    Thanks so much.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •