Community Forums
Results 1 to 5 of 5

Thread: IDriver.exe crash

  1. #1
    Join Date
    Oct 2005
    Posts
    3

    IDriver.exe crash

    Running XP Sp2, InstallShield 11 pro

    Relative to the crash at the end of the installation on my computer...

    [2660] C:\Program Files\Common Files\InstallShield\Driver\11\Intel 32\IDriver.exe

    Unhandled exception at 0x77511029 in IDriver.exe: 0xC0000005: Access violation reading location 0x0000005c.

    Disassembly
    77511029 cmp dword ptr [esi+5Ch],eax


    any clues?

  2. #2
    Join Date
    Nov 2005
    Posts
    51

    IDriver.exe crash

    Hi,

    I think you'll find the solution at http://support.installshield.com/kb/...icleid=Q107216
    will also apply to your situation

    Regards,
    Dsilva.

  3. #3
    Join Date
    Feb 2005
    Posts
    10
    Has anyone found a solution for this problem?

  4. #4
    Join Date
    Sep 2006
    Posts
    10

    Help please! Application Error in Idriver.exe

    I too am running into this problem. I have configured a major upgrade from our last installer-- updated the upgrade table, created a new product id, etc. It all works fine, but at the very end of the major upgrade (after OnEnd, after everything else seemingly) I get the very same Idriver.exe exception. The exact message I get is:

    IDriver.exe - Application Error

    The instruction at "0x77511029" referenced memory at "0x0000005c". The memory could not be "read".

    I tried this with verbose logging enabled for the major upgrade installer, and the problem goes away.

    This is for an Installshield 11 project, hotfixes applied, running on Windows XP SP 2. The Idriver.exe version is 11.0.0.28844.

    Any help would be greatly appreciated.

  5. #5
    Join Date
    Sep 2006
    Posts
    10

    results of seeking help

    Extensive asking-around did not turn up a workaround... but luckily the problem seems to be confined to the actual Installshield dev box in our case. QA hasn't repro'd it elsewhere. For those stuck with this problem, some useful advice is here:

    http://community.installshield.com/s...02&postcount=2

    Also, one of our resident gurus had this to say:

    "I have a feeling that during the upgrade process, a relationship between two features is missed when Installshield is determining it's activities and one of the threads has a message from an InstallShield employee that describes a circular reference issue.

    In the third one: http://community.installshield.com/s...d.php?t=155239 one response recommends changing features with 'Require = no' to 'Required = yes'. Have you tried that? That would override the issue by ensuring that a feature relationship is honored.

    However, in the second thread http://community.installshield.com/s...d.php?t=163143 they recommend launching the uninstall as a separate process using a silent install. That would likely fix the issue because instead of doing an upgrade you are essentially doing an uninstall, install."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •