Community Forums
Results 1 to 5 of 5

Thread: IIS errors (27500) when component not selected

  1. #1
    Join Date
    Jul 2005
    Location
    Canberra, Australia
    Posts
    3

    Question IIS errors (27500) when component not selected

    Hi there,
    We just upgraded to IS11 yesterday. We're now having some difficulty with installing a package that contains a web app as an optional feature (not installed by default). Problem is that even when the feature is not selected (as most users would not need it nor have IIS installed) the user still gets an IIS not installed error (27500). However, the creation of the virtual directory is contingent on a component associated with the Web feature and so ultimately this should not be an issue.

    I have seen the KB article that its required for any functionality, but surely installshield can work out whether or not it needs it through the components selected (and not raise an error if its not required)? Otherwise we have to go back to telling everyone to set up this directory manually to cater for those without IIS!

    Any help or ideas would be fantatic.
    Thanks in advance,
    Steve

  2. #2
    Join Date
    Dec 2002
    Location
    Portsmouth, New Hampshire
    Posts
    17
    I am having an identical problem in my project. InstallShield, please break the silence....
    ~~
    Bryan Garretson
    Release Engineer
    DesktopStandard Inc.

  3. #3
    Join Date
    Dec 2002
    Location
    Portsmouth, New Hampshire
    Posts
    17

    fix?

    I managed to get this working in my project, by doing what InstallShield should be doing already... try this:

    Restrict the following custom actions in your Sequences table to the following condition (YourComp is the name of the component to which you have associated the IIS Virtual Directory creation):

    &YourComp=3

    caExtractIISSuppFiles
    caRlBackVRoots
    caRemoveVRoots
    caCreateVRoots
    caIISCleanup

    This will manually prevent any IIS related activity from taking place without the component that actually needs it being selected.

    Let me know if it works?
    ~~
    Bryan Garretson
    Release Engineer
    DesktopStandard Inc.

  4. #4
    Join Date
    Jul 2005
    Location
    Canberra, Australia
    Posts
    3
    G'day Bryan,

    Thanks heaps for that, it works a treat. You're right, it is something that should be factored in automatically. I used to use &Component=3 with developer 8 (which we just stopped using) which was ok, but wasn't sure how to lock v11 down.

    Thanks again for your help - most appreciated!

    Regards,
    Steve Craze

  5. #5
    Join Date
    Jul 2002
    Location
    Deutschland
    Posts
    209

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •