Community Forums
Page 11 of 11 FirstFirst ... 91011
Results 51 to 54 of 54

Thread: The wizard was interrupted before [APPNAME] could be completely installed.

  1. #51
    Join Date
    Oct 2006


    I found this: had solved my problem.

    The point is there is something wrong with Microsoft Windows Script 5.6, whether it's corrupted or outdated. All you need to do is reinstalling it. Here are the links:

    Hope helps.

    Maximilian Haru Raditya

  2. #52
    Join Date
    Sep 2008
    I have a U.S. XP Pro computer recently updated to SP3 (updated not re-installed). This computer also had Microsoft AppLocale and East Asian languages installed for Japanese support. The program in question was a setup.exe that unwrapped it's setup.msi in the %temp% folder during installation.

    I figured out how to get a log file using these options: setup.exe /V"/Liwe c:\setuplog.txt" where the /V switch passes command line options through to setup.msi, /L creates a specified log file, i logs status messages, w logs non-fatal warning messages, and e logs any error messages. The relevent information from the logfile was this:

    Action start 20:51:37: InstallFinalize.
    Error 0x80070003 opening directory D:\localization\espanol
    Action ended 20:52:37: InstallFinalize. Return value 3.
    Action ended 20:52:48: INSTALL. Return value 3.
    Action ended 20:52:48: ExecuteAction. Return value 3.
    Action start 20:52:48: SetupCompleteError.
    Action ended 20:53:06: SetupCompleteError. Return value 2.
    Action ended 20:53:06: INSTALL. Return value 3.

    I opened the noted path and found that it was actually D:\localization\español . In fact the installer failed to copy any accented file or folder name.

    I went to run applocale and found that it was not properly installed so I uninstalled it. I also removed the East Asian languages and installed Windows Installer 4.5 XP 32-bit edition WindowsXP-KB942288-v3-x86.exe. After doing these three things and rebooting the computer the installation went fine.

    I'm not inclined to try to reproduce the problem but it could have been related to the SP3 upgrade, East Asian languages, AppLocale or even the Microsoft installer. Ultimately the way that it failed on the accented characters is the key thing. Perhaps this will be helpful to someone else.
    Last edited by noabody; 09-21-2008 at 02:06 PM.

  3. #53
    Join Date
    Dec 2010

    Error installing a web app in Windows Server 2008

    For me, the error occurred on moving to Windows Server 2008. A web application ( had been installed fine on XP and Windows Server 2003, but unsuccessfully on WS2008.

    I finally made some progress in diagnosing the problem after generating some log files adopting the suggestions posted earlier. The way I did it was:

    1). Open up an administrator’s Command Prompt. To do it in WS 2008, you cannot just open the Command Prompt. You need to run as administrator opening it:

    Start Menu > All Programs > Accessories > right-click Command Prompt > Run as administrator.

    2). Then call the installer with parameters to generate a log file:

    msiexec /i xxx.msi /liweav setup.log

    Parameter /i specifies the msi file, xxx.msi, in this case. Parameter /l or /L specifies log options and log file, setup.log in the current folder, in this case.

    Alternatively, if you have a setup.exe:

    setup /V”/liweav c:\temp\setup.log”

    3). Look for Return Value 3 and its context in the log. In my case, the focus is on the following:

    Action 10:48:21: caRemoveVRoots. Removing IIS Virtual Roots...
    MSI (s) (64:F4) [10:48:21:236]: Executing op: CustomActionSchedule...
    MSI (s) (64:48) [10:48:21:251]: Invoking remote custom action...
    1: Unable to open the IIS Admin Service
    1: Error with IISRT: -1102
    Action ended 10:48:21: InstallFinalize. Return value 3.

    4). So, my problem was due to the installer not able to open the IIS Admin Service. I was sure IIS was running and surprised to find that IIS Admin Service did not even exist in Services (Server Manager > Configuration > Services). To make a long story short, I needed to add IIS 6 Metabase Compatibility to IIS 7 (with Windows Server 2008).

    Server Manager > Roles > Web Server (IIS) > Add Role Services > Management Tools > IIS 6 Management Compatibility > IIS 6 Metabase Compatibility

    With that installed, IIS Admin Service is now showing in Services. And that solved the problem.

    So, the "wizard was interrupted" error can be due to XP SP 2 or any of the many problems that the installer does not know how to handle. It may require some in-depth investigation by creating a log file and reading it closely in order to find the actual problem.

    Thanks to this thread, the contributors, and the replies. It all helps solve my particular problem.

  4. #54
    Join Date
    Feb 2014

    Installshielfd error

    Quote Originally Posted by bigosmj View Post
    Unfortunately, I am simply another end-user reporting the same behavior. I wanted to provide as much information as I could about my situation, because I think it might be helpful. (I am a .Net software engineer, so feel free to treat me as a user with a high technical background.)

    I came across the problem when reformating and reinstalling my XP SP2 system. Specifically, this time I reinstalled Windows using my new "Windows XP Pro with SP2" CD. I only had reinstalled a few titles before the "the wizard was interrupted" InstallShield error message occurred, also with a Quicken product, as other users have reported - Quicken 2004. The exact list of Windows Installer titles from the Event Log were these:

    {54DE0B75-6CD9-44C4-B10A-1F25DA9899D8} Quicken 2004
    {790EC520-CCCC-4810-A0FE-061633204CE4} ISScript
    {121634B0-2F4A-11D3-ADA3-00C04F52DD53} ByteFX MySQL .Net Client
    {35D027A4-57BA-4E59-94DB-DFB36FFFDC1E} Remote Desktop
    {FCE65C4E-B0E8-4FBD-AD16-EDCBE6CD591F} XP CD Writing Wizard (from Windows Update)
    {5757AE1A-1DB4-4898-9806-09F77FBD5E57} MSDN
    {20610409-CA18-41A6-9E21-A93AE82EE7C5} VS.NET 2003
    {1A655D51-1423-48A3-B748-8F5A0BE294C8} J# Redistributable runtime
    {CB2F7EDD-9D1F-43C1-90FC-4F52EAE172A1} .Net 1.1 (runtime?)
    {D4D24FE5-FAB3-4FE2-AFFC-623955F4DF3A} VS.Net baseline
    {17B66E83-1BC9-11D5-A54A-0090278A1BB8} Frontpage client
    {FAAA508A-05C0-488B-BFC2-F9217E545A81} Logitech gaming
    {CF6E7481-4487-46D3-810A-F73EEA232CE0} Intellipoint
    {81463B08-A929-4125-A5F4-1B053AC35A09} Intellitype Pro
    {91110409-6000-11D3-8CFE-0150048383C9} Office 2003
    {350C97B0-3D7C-4EE8-BAA9-00BCB3D54227} Web Folders XP

    After some web searching, I tried a few workarounds: I tried explicitly defining Default Access permissions in DCOM. As I recall, I tried added the local Administrators group, Interactive and System, in independent attempts, with reboots inbetween.

    I tried using the Orca editor from the SDK to modify the isscript.msi from the Quicken CD (copied to HD) to add table values from the attached (obtained from this board, I think.)

    In the end, I copied Quicken 2004 from another non SP2 computer to mine, used SysInternals File Monitor ( to find DLLs from the install that were missing, and extracted them from the file into the system32 folder. Definitely not a clean install - I'll be awaiting the times when I invoke an action with another missing DLL, crash Quicken and lose a night's worth of entering bills. I'll plan to provide these details to Quicken support too, although we'll just have to see who (Quicken, Microsoft, InstallShield) is able to provide the best end-user solution long-term.

    Feel free to post here if anyone wants me to try a solution - I'll subscribe to the thread.

    Michael Bigos

    Mine is not really reply but a confirmation the this error can sometimes be difficult to solve. I am having the same problem now but I am sure the problem is the installshield and not my computer. because packages created before this error started coming showing all install without problems.

Page 11 of 11 FirstFirst ... 91011

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts