Community Forums
Results 1 to 2 of 2

Thread: Newbie: Installing new version over an existing one

  1. #1
    Join Date
    Nov 2001
    Posts
    53

    Unhappy Newbie: Installing new version over an existing one

    Hello everybody,
    I just updated from Installshield Express 2.11 to 3.51 and have some problems. In the 2.11 version every build of our software was just installed over the existing one. E.g. our software name was xxx 4.4 Build 12 and the installation of Build 13 replaced the build 12. I do not know who to provide the same solution with the 3.51 version of ISExpress?

    First I tried using this Upgrade path thing. But my problem is that I can´t tell the program the GUID of the version I want to replace, because some people skip single builds. That means e.g. my build 18 should replace every former build of the produkt. And due to definition of the Upgrade Path Utility every update of a program needs to have a new GUID...

    Question: Isn´t it possible to force the Installation to replace every former version with the same GUID, without prompting a "Please uninstall first"? Maybe with some command line parameters in the setup.ini?


    Thank you
    Jürgen

  2. #2
    Join Date
    Oct 2001
    Posts
    4,852
    The Upgrade Path feature is supported for Windows Installer setups only. That means only setups created with Express 3.x upwards. The Upgrade is based on the Upgrade Code and NOT the Product Code. So as long as you Upgrade Code remains the same across all the Setups, only one Upgrade Path is needed to upgrade them all to the newest version.

    As for your case I'm afraid you will have to use Custom Actions to uninstall the previous versions before installing the new one.
    Chandima Rajakaruna
    Macrovision Corporation

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •