Community Forums
Results 1 to 4 of 4

Thread: Error 2711 (feature name is not in feature table).

  1. #1
    NirArpi Guest

    Error 2711 (feature name is not in feature table).

    I build a simple ordinary ism project with 3 different features.
    After a successful compilation I tried to run the setup.exe that I created.
    During the installation (i.e. during the run of the setup.exe) I get the following error:
    'Internal Error 2711. VS.Net_Common.’
    The VS.Net_Common is one of my features in my ism project.
    In the help files of InstallShield I found that error 2711 means that: 'The specified Feature name not found in Feature table’.
    How can it be and how can I solve this?
    Thanks.

  2. #2
    Join Date
    Jan 2011
    Posts
    58
    I know its a very old issue but maybe it will help to others
    I faced the same issue when i realized that one feature had a release flag that is not mentioned in the releases flags in the release buyild in "Releases" section via Installshield.
    if this is the situation then the MSI release wont include that feature in its feature table list. therefore the msi does not recognize the feature
    usually it heppends when you set ADDLOCAL property to tell the msi which features to install

  3. #3
    Join Date
    Sep 2011
    Posts
    10

    Running MSI from a long path also causes error 2711.

    I was getting this error when using ADDLOCAL=FeatureName with same MSI on one machine but not on other. Further investigation revealed that when I run MSI from a very long path then error happens but if I run it from a shorter path then the issue is not seen.

  4. #4
    Join Date
    Nov 2007
    Posts
    23
    Again I know this is an old thread but I have had this problem bugging me for a day - perhaps this can help someone in the future..
    Basically I had an old installer which had a couple of component parts and all bar one were being removed to make a new installer. I moved the feature I wanted up to the root and deleted the old root - thus so the custom Setup page was correct. However, I hadn't changed the feature from being 'Favour Parent' to 'Favour Local'.

    Obviously (well now I've spotted it) a root item does not have a parent to follow - and Installshield doesn't recognise it's now a root and stop this option (or flag it up in a meaningful message). In fact this seems that for root features it's possible to choose 'Favour Parent' as an option - which to me doesn't make any sense...
    Last edited by Phatado; 04-21-2017 at 06:28 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •