Community Forums
Page 1 of 2 12 LastLast
Results 1 to 5 of 9

Thread: Shortcut folders not uninstalling?

  1. #1
    nsg1975 Guest

    Shortcut folders not uninstalling?

    Hi:

    I have a fairly simple setup that creates the following shortcuts:
    1) Launch app executable (start menu)
    2) Launch app executable (desktop)
    3) Uninstall app (start menu)

    Installation works fine. The start menu shortcuts are created below 'Company\Product Name\' subfolders as expected.

    When I uninstall, the shortcuts all get removed, HOWEVER, the created shortcut subfolders almost always remain.

    e.g. All Programs -> Company -> Product Name -> <empty>

    They don't seem to go away, either. I tried rebooting several times, etc. I tried uninstalling it different ways (from add/remove, from the uninstall shortcut, from setup.exe, etc.) and it doesn't seem to matter.

    Yesterday I ran the setup/uninstall about 8 times and it only uninstalled the shortcut folders once.

    What do I need to do to get these things to go away consistently after uninstall?

    Thanks!

  2. #2
    Join Date
    Oct 2001
    Location
    Schaumburg, IL
    Posts
    849
    Are the folders present before you run the install? Make sure you are testing on a relatively clean folder structure.

  3. #3
    nsg1975 Guest
    No, the folders aren't present prior to the install (at least they don't show up in the start menu listing).

  4. #4
    Join Date
    Oct 2001
    Location
    Schaumburg, IL
    Posts
    849
    I would check them in Explorer too...I do not remember running into this problem during our testing phase. But if there is something I can do to fix it, I would like to.

  5. #5
    nsg1975 Guest
    Ok, just checked the folders in explorer as well, and they are definitely gone prior to install.

    Here's another bit of info I just discovered. I successfully installed/uninstalled the app 3 times in a row. As long as I didn't actually click any of the start menu shortcuts, the shortcut folders uninstalled properly.

    Then I installed, clicked the "Launch app" start menu shortcut, exited the app, and uninstalled. The shortcuts were gone, but the shortcut folders remained...

    I then right clicked the remaining shortcut folder and selected "explore". Both shortcut folders showed up, and both were empty. I then tried to delete them from explorer, and was told that it couldn't be deleted because it was being used by another person or program...

    I then rebooted, and the empty shortcut folders were still present. I was then able to successfully delete them from explorer.

    I'm running XP, and have been selecting the "Install for all users" setting during setup.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •