Community Forums
Page 2 of 4 FirstFirst 1234 LastLast
Results 6 to 10 of 19

Thread: Error -5004 0x80070005

  1. #6
    Lagulec Guest

    -5004 0x80070005, same error

    I got the error -5004 0x80070005 too...

    But I've got it even logged with admin rights...

    Has anyone an solution for this problem ?

  2. #7
    atfaniqbal Guest

    Unhappy Error Code -5004 : 0x80070005

    Error Code: -5004 : 0x80070005
    Error Information:
    >SetupDLL\SetupDLL.cpp (1924)
    pAPP:InstallShield Engine Update 701
    PVENDOR:Your Company Name
    Attached Images Attached Images  

  3. #8
    Join Date
    Nov 2004

    error (-5004 : 0x80070005)


    I am also getting the Error 5004 0x80070005 while executing any setup created with Installshield Prof. 7.01.

    OS: Windows XP SP1

    I reach the screen “Preparing Setup” and then get the error message “An error (-5004 : 0x80070005) has occurred while running the setup”.

    Has anyone found a solution to this problem?

  4. #9
    Join Date
    Feb 2005
    Too little to late maybe but I had this problem and found a way round it, basically it is to do with permissions


    Yeah i'll go on, ok I ran cmd and at the command prompt I typed in "at time /interactive cmd.exe" replace time with a valid time either 1 or 2 minutes ahead for example its 12:00 so I'd use 12:01, at the time you specify a command prompt console will appear, this is no normal command prompt it has system rights and if you browse to the install package you are trying to run and run it then it should install fine, there could be an issue if the program that you install needed the permissions that it needed for the install but you'll probably be ok, it worked for me anyway

  5. #10
    Join Date
    Jun 2005

    Error -5004 0x80070005

    Good answer by Ted.. it is an access rights problem.

    I had the same Error -5004 problem and it took several days of troubleshooting.

    The 'Setup' I was running was for the game Star Wars Knights of the Republic 2. I also tested the 'Setup' for Apple's iTunes for Windows and this also failed but with a more helpful error message because it showed the heart of the problem.

    The iTunes setup complained about the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
    that could not be accessed. Actually the permissions for that key belonged to only one user with a funny name (S1-2134-blahblahblah..). I added the Administrator group to the permission of that key and deleted the S1-blahblah user from the permissions.

    Afterwards the 'Setup' application still couldn't finish but terminated further up in the installation. It complained about not being able to access the registry key Unkown/CLSID/blahblah. I searched for that entry in the registry but came up dry (sorry for the "blahblah"s above because I didn't write down the exact name of the keys).

    So I propagated the permissions of the key HKEY_LOCAL_MACHINE\SOFTWARE down to its child objects with these steps:

    1) Right click on the key HKEY_LOCAL_MACHINE\SOFTWARE
    2) Click on 'Permissions...'
    3) Under the tab 'Security' click on 'Advanced'
    4) Tick on the checkbox of 'Replace permission entries on all child objects with entries shown here that apply to child objects'

    After this the iTunes setup finished successfully. I also re-setup the Star Wars game but with less success... it complained lack of free space

    All things said, I am not confident about the impact of the latter steps above (propagation of permissions) to the integrity of Windows and the other applications. Your thoughts, anyone?

    My guess for the first permissions problem is: Prior to me, my PC was used by another person. He left the company a few months ago and our domain server must have deleted his username in its database and this caused the funny user name in the Permissions of the registry key.

    Your comments are welcome.

    With regards,
    Thomas Victorio

    Quote Originally Posted by tw0001
    the subcode 0x80070005 means "access is denied" so there is something that InstallShield is detecting as not having the proper rights to. Can you try the following. Go to the physical terminal server machine and log on as administrator (not through terminal server but directly on the computer) and see if the error still comes up. If it does not, then you know that there is some access right that needs to be given, for example, to "Program Files" folder or HKEY_LOCAL_MACHINE\Software


Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts