Community Forums
Results 1 to 3 of 3

Thread: CopyFile always returns 'Access is denied' in Win98 even though file is copied

  1. #1
    stewed Guest

    CopyFile always returns 'Access is denied' in Win98 even though file is copied

    I have an InstallScript project that installs a number of files by copying them from a website (using CopyFile). When the installation is run in Windows XP it works perfectly. When I run the installation in Windows 98 (and Windows ME) CopyFile always returns the error code 0x80070005 (Access is denied) even though the files are successfully copied (I have verified that the files don't exist before the installation, and that they do exist after the installation). This results in the files not being logged, which means that they aren't removed during uninstallation. I've tried using XCopyFile instead of CopyFile, but it behaves exactly the same way.

    What can I do? Is there a simple workaround for this bug? I want to avoid writing lots of script code for logging and deleting the files myself...

  2. #2
    Join Date
    Oct 2001
    Location
    Schaumburg, IL
    Posts
    407
    Hi,

    Is this a different problem than the one you're working with Devin on in this thread? If not, please continue to work in that thread. There's no need to create a new one.

    Rich

  3. #3
    stewed Guest
    Oh, sorry about that. After a couple of days with no response I assumed you considered that thread closed. Technically, the reason why the files aren't logged (being the problem discussed in that thread) was in fact found, so I thought I'd start a new thread dealing with the origin of the problem (invalid error codes from CopyFile).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •