Community Forums
Results 1 to 4 of 4

Thread: URGENT: LaunchAPP on uninstall causes add/remove applet to hang

  1. #1
    pazurik Guest

    Exclamation URGENT: LaunchAPP on uninstall causes add/remove applet to hang

    Hi,

    I have submitted this question under a prior thread but now have determined further details that will assist in clarifying the problem.

    I need to launch an app "x.exe" (no wait) when the application uninstalls. If the uninstall is done from an uninstall shortcut, it works as expected, if it is done from the add/remove applet, the uninstall finishes as expected and x.exe is launched as required but the add/remove applet hangs and will not be unlocked until x.exe is closed.

    I have confirmed this happens on all Win2K PCs but does not seem to on Win98. I have not tested on XP.

    I have created a small install to test this and it behaves the same even though the app launched is notepad.exe

    Any assistance is greatly appreciated!!!!

    Aaron
    Attached Files Attached Files

  2. #2
    Join Date
    Jul 2002
    Posts
    826
    pazurik,

    Sorry, I thought I responded to the other thread but I guess I didn't.

    You are correct the Add/Remove programs applet waits until any process launched from the initial proccess completes.

    I'm not sure why this works differently in 6.x than 7.x, most likely the change is due to the fact that 6.x launched an addition process via. IKernel.exe, in 7.x, IKernel.dll is used.

    Unfortunately, since I'm not sure exactly how the Add/Remove panel decides whether or not wait I have not found a way to get the Add/Remove panel to not wait for the launched application in 7.x, perhaps a solution would be to launch a small app. that launces the additional app. and then ends.

    Devin Ellingson
    InstallShield Software Corporation

  3. #3
    pazurik Guest
    Thanks for the quick reply Devin. Too bad that this is an issue. I'm surprised a bit by this limitation since I can see many times when you would want to launch an application on uninstall (view notes, etc). I understand part of the issue is with the add/remove applet behaviour.

    Will attempt a workaround but will only have time now to implement a big fat message to indicate that the app can not be launched as required.

    cheers,
    Aaron

  4. #4
    Join Date
    Dec 2016
    Posts
    2
    This issue still exists in InstallShield 2010 SP1, Please let me know whether we had any solution for this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •