Community Forums
Page 1 of 2 12 LastLast
Results 1 to 5 of 7

Thread: Dialog Uniformaty not working

  1. #1
    betoski Guest

    Unhappy Dialog Uniformaty not working

    Everything in my setup.exe is working great, except for one minor thing that just doesnt look professionl to me. I dont know if this is a bug or not, but I've customised my dialogs via the "global dialog settings" and included a spalsh screen. All of the dialogs look fine except for the "Preparing to Install" dialog when you first double click on the excutable. This happends on both the first installation and with you double click on the exe, once installed, for repair or removal. That dialog still displays the Install shield logo on the left .

    My question is. Why isnt is changing the logo via the global dialog settings? Is there somewhere I disable the "Preparing to install" dialog? Is there anyway once you double click on the setup to go straight into the "Splash screen?" Please Help!

    Your help would be greatly aprechiated as this is the final step before I release.


  2. #2
    Join Date
    Oct 2001
    Posts
    4,852
    This dialog you talk about actually comes from Setup.exe. The "Global Dialog Settings" properties are associated with dialogs in the msi file. Once you launch Setup.exe, it starts seeing whether you have the minimum requirements for the Windows Installer and whether the msi engine needs to be installed. Since this takes a while (and we don't want to give the user the impression that nothing is happening) we make Setup.exe show this dialog. Once everything is done it will launch the msi, which in turn launches the dialogs.

    Good news is that you can suppress this dialog. Try running setup.exe with the following Command Line:

    Setup.exe /s
    Chandima Rajakaruna
    Macrovision Corporation

  3. #3
    betoski Guest
    This is exactly how i expect the setup to run. Now, is there anyway to incorperate this into the exe so it works this way when you double click it? I mean, this would be perfect if it worked when you double click on it. Please help.

  4. #4
    betoski Guest
    I've tried almost every setup.exe on my pc and noticed over 95% of them do not show that dialog box. So theres is a way...Should i upgrade to professional or developer? Anyone know a work around that will work without going to the command promt and typing /s?

  5. #5
    Join Date
    Oct 2001
    Posts
    4,852
    I thought we could specify the /s parameter in Setup.ini but it doesn't seem to work. I just emailed our Setup.exe developer with the question. Will let you know what he says.
    Chandima Rajakaruna
    Macrovision Corporation

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •