Community Forums
Results 1 to 5 of 5

Thread: Failure to detect Internet connection

  1. #1
    Bruce Rees Guest

    Exclamation Failure to detect Internet connection

    Hi,

    I'm having a problem with the Update Service recognizing (or not recognizing) a live Internet connection. On two of 5 machines that we've tested on (both XP Pro) the Update Service reports no connection with both machines connected (cable) and able to surf, email, ping etc.

    On a third machine with a satellite connection (dialup out, broadband down, high latency) the Update service failed to see the connection if any other activity (eg an upload) was happening. This would seem to imply a timeout issue with the connection test code..

    I'm now getting it in the neck from those higher up so I would appreciate any help or advice!

    Thanks!

    Bruce Rees

  2. #2
    Join Date
    Jan 2002
    Location
    Schaumburg, IL
    Posts
    331
    Bruce,

    It could be a timeout issue. In fact, we believe some of the other issues reported as ZoneAlarm issues are possibly timeout issues as well.

    Our methodology: We ask windows if a connection is present. If so, we go to our server to see if it is alive. We wait 2 seconds for a response. If no response, we assume no connection (or you can't reach our server) and display the "internet connection" dialog that you see. Why did we choose 2 seconds? We tested over a slow AOL connection with another download running. In our testing, 95% of our requests were returned in less than 2 seconds.

    To prove this is a timeout issue, please try the steps posted by Sandeep:

    http://community.installshield.com/s...2&pagenumber=3

    This will fake IsConnected() to always return true - esentially skipping the Internet check. We are interested to know if the rest of the Update Service will still work (updates will be displayed properly). This will tell us if the problem is in the Internet check or if the Update Service just can't see the Internet for some reason.

    Please let us know ASAP.
    Chris Woerner
    InstallShield Software

  3. #3
    Bruce Rees Guest
    That worked..with the registry entry in place, the update service was successful in connecting.

  4. #4
    Bruce Rees Guest

    Question Any progress on the connection bug?

    Hi Guys,

    Haven't heard anything back from you about the Internet Connection issue.. We're ready to roll-out for real and I need to report back urgently..

    Thanks!

    Best Regards,
    Bruce Rees

  5. #5
    Join Date
    Jan 2002
    Location
    Schaumburg, IL
    Posts
    331
    Bruce,

    The good news is that this was a timing issue. The question is how to deal with the issue until we can make the timeout a configurable parameter.

    How are you calling the Update Service?
    - from the menu
    - during start-up (if so, which API?)

    Will your users be connected?

    BTW- in the future if you have an issue that needs immediate attention, you should contact our support group. We try to post on a regular basis to the community, but the support group is better at tracking individual issues and raising priorities.
    Chris Woerner
    InstallShield Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •