PDA

View Full Version : .Net Installer class -6241: Internal build error



ratimics
07-30-2002, 07:18 AM
Hi All

I have a .Net assembly which contains a class derived from System.Configurations.Install.Installer but when i set the .Net Installer class of the File to "Yes" i get the following error when building a release:

"Adding Installer namespace CustomActions for .NET assemblies
** Fatal Error: -6241: Internal build error"

when i run InstallUtil on however it works fine and installs the service as designed.

Any help would be appreciated

Thanks

®

Art Middlekauff
07-30-2002, 05:37 PM
That error only occurs if the build has trouble adding InstallUtilLib.dll to the Binary table. Does your project have any other items in the Binary table? Does the build complete? What entries are in the Binary table of the built package?

ratimics
07-31-2002, 03:53 AM
Hi again Art (for it seems you answered my other Querey as well)

The build seems to complete but not correctly as it displays the following message directly after the error message:

"PlantStar\Release 1 build completed with 1 errors, 5 warnings"

There are a number of other items in the binary table (but i think they were all added by installshield), namely:

InstallScript, IsConfig.INI, ISRT.DLL, ISScriptBridge.dll, String1033.txt, ISSELFREG.DLL, ISSetupFilesHelper

Do you think any of these could be affecting it?

Thanks
®

ratimics
07-31-2002, 04:48 AM
Hi All

I solved my problem (turned out to my own stupidity combined with unclear option from Installshield)

Under the .NET tab in Tools|Options it asks for the LOCATIONS of Installutillib.dll and regasm.exe so I put the directory where these files are installed (copied from explorer). What it actually wants is a path to this file INCLUDING filename. If you click browse and browse to the directory and choose it, it then gives an error message that this is a folder (but not if you copy it directly there) and you actually need to select the specific file requested

eg for Location of InstallUtilLib.dll you need to put something like:

"C:\WINDOWS\Microsoft.NET\Framework\v1.0.3705\InstallUtilLib.dll"

note the filename.... once you have done this it all works as expected.

Sorry for the inconvenience caused
®

:o