PDA

View Full Version : Upgrade does not install any new or modified files



Corpse
07-30-2002, 06:29 AM
I'm getting really frustrated about using Installshield. Why the hell are some of my new and modified files not installed? I've searched this forum and applied every suggestion I could find, but no dice.

First I tried using parameters:
REINSTALL=ALL REINSTALLMODE=vomus

But this didn't work so I tried installing all files using :
REINSTALL=ALL REINSTALLMODE=vamus

The log states these command-line options, but further on I find lines like:
MSI (s) (A4:08): Component: DB; Installed: Local; Request: Null; Action: Local
MSI (s) (A4:08): Component: DB_OLD; Installed: Absent; Request: Null; Action: Null
MSI (s) (A4:08): Component: MMS_OLD; Installed: Absent; Request: Null; Action: Null
MSI (s) (A4:08): Component: MMSHelp_app; Installed: Local; Request: Local; Action: Local
MSI (s) (A4:08): Component: MMS; Installed: Local; Request: Null; Action: Null
...

Now new files are in components: DB_OLD and MMS_OLD, modified files are in MMS and files in DB and MMSHelp_app are still the same. Why are the files that are new or modified not copied?

I'm working on this for a few days and I'm thinking of sending Installshield Developer back from where it came from asking for a refund!!!

amaddux
07-30-2002, 07:15 AM
Are you using the latest service pack? Also, it shouldn't matter, but you have your parameters in the opposite order as I have them. When you have it correct, your log file should show the action for each feature to be Reinstall.

I had a few problems getting it to work until I got Service Pack 4.

Hope this helps.

Corpse
07-30-2002, 07:37 AM
Thank for a quick reply and giving me some hope again! Well, I do have the latest service pack 4, so that shouldn't be a problem. Could you please provide me with the exact parameterlist that you are using and that is working for you?

Thanks a lot!

amaddux
07-30-2002, 08:43 AM
I'm using the parameters:

REINSTALLMODE=vamus REINSTALL=ALL

I'm also catching the OnResumeUIBefore and OnResumeUIAfter to run the same script as OnFirstUIBefore and OnFirstUIAfter.

My InstallShields are now working like they did under 5.x as far as I can tell.

Corpse
07-30-2002, 04:27 PM
In the releases view I checked my parameters and they are exactly the same as yours. The attached log was created when executin msiexec manually, but when using the installshield generated setup.exe the problem remains. Some of the components are not installed regardless of the fact that they are missing or modified.

Anyone, please shed some light on my problem. I'm hopelessly stuck and am about to give up on installshield alltogether.

amaddux
07-30-2002, 04:36 PM
Are you doing a standard or basic type of installation? I am doing standard, and cannot run my msi without using the setup.exe.

Also, did you leave your attachment out of your post? Or am I missing it? You can also make a log using the setup.exe

Corpse
07-30-2002, 04:55 PM
I'm using a standard project. The log is attached now.

Additional info: it's not only files that aren't copied, also a new component containing a ODBC Datasource isn't installed.

amaddux
07-31-2002, 07:12 AM
Corpse,

It is a new component and not a new feature correct? Is the new compoenent part of an existing feature?

Corpse
07-31-2002, 07:48 AM
Two kinds of flavour:

[list=1]
new components within existing features
modified components within existing features
[/list=1]

I'm not using any new features at all.

amaddux
07-31-2002, 08:24 AM
I wonder if that is the cause of your problem. I'm pretty sure I read something about changing the components in an existing feature could cause problems. My compoenents and features stay pretty much the same, so I would guess that is the cause of your problem.

Corpse
07-31-2002, 08:35 AM
Ok, let's say I would try only to use new components and not modify existing components. How would I go about to modify files from the original installation, because that is something that must be don.

gauravwadhawan
07-31-2002, 10:32 AM
Hey Corpse,

Take a chill pill man...

We all are sailing the same boat out here, facing the same problems.

OK ! To modify your existing files and in case they are versioned files do change their version to the latest in the file table. I hope this will atleast help u modifying the versioned files.

And for the non-versioned files you'll have to use install script to delete those non-versioned files in the On_Begin event. The upgrade will find those files missing and replace them.

All the best

Corpse
07-31-2002, 10:41 AM
I'm normally speaking a java programmer and programming an java application to copy a few files and modify a few others would take me about 1 hour, tops! But the Boss wants a fancy Installshield installer so I'm working on this for days now. Ready documentation that is, in my opinion, hardly readable doesn't make my day any better. So forgive me if I'm a bit frustrated, but that's the situation.

Back to business:
I can try the suggestion of delete files in OnBegin, because my files are not versioned. Looking at my logs, some of the files are found to be missing by the installer but are not installed anyway, so deleting existing files wouldn't help at all. Besides I have tried to manually delete some of the files installed by a previous installer, but that doesn't do anything. Those files remain abscent after my upgrade.

amaddux
07-31-2002, 10:48 AM
Corpse,

Don't worry too much about days. It took me months to convert our Install Shields from 5.5 to 7.04 Turns out there were a lot of changes in that time, and our InstallShields were quite complex.

A lot of the problems I encountered were fixed in the 4th Service Pack. It is possible to get it to work correctly, but it may take a lot of very frustrating days. I almost went back to 5.5 several times.

Corpse
07-31-2002, 10:55 AM
It's a bit of a relief to hear that many others are struggling with Installshield as well. Would it be wrong to state that it's everything but a intuitive and easy-to-use tool. I have seen quite a lot of installshield installers the past couple of years, so I really thought it couldn't be all that hard to create a nice installer (new or upgrade). By now I know that that is not true. The people that get their installation right must be geniuses!

deecole
07-31-2002, 11:38 AM
Your frustrations are probably due to the Windows Installer file versioning rules instead of InstallShield.

Look at the key file of each component that is not being installed. If the key file is an executable, does it include version information, and is the version information incremneted in the later file?

It looks like MSI believes the component is already installed, and thus sets the install action to null. This can happen if you have missing or unchanged version info.

See "File Versioning Rules" in the MSI help for details.

David

rayhawk
10-28-2002, 04:17 PM
. . . and my files _are_ versioned.

Our ODBC drives/source is not being updated, via /fvomus or through an actual install.

Did anyone have a resolution to this?

randyhersom
04-09-2003, 04:21 PM
I had a temporary resolution by right clicking under Components-Files, unchecking Use System Attributes and setting the file version and size by hand. That stopped working a couple months later and now I'm in the same frustrating boat. Can't anybody explain EXACTLY how Microsoft makes their stupid decisions?

mjmcmahon
10-15-2003, 08:22 PM
Hi guys,

This morning I was having a problem with something similar to you. I had recompiled a component which I had produced earlier in the day... but found that for some reason the Installer wasn't picking up the new component.

I tried everything from unregistering and removing the old component before replacing it, making sure the installer project was closed when I replaced the file... restarted Installshield and Windows numerous times. Tried uninstalling the product and re-installing, changing the caching options for the release file, I added a 'v' to the reinstallmode property but nothing seemed to work.

Eventually I found that I could work around the problem by increasing the build number of the component (it's a visual basic activeX exe) and then the Installer recognised that it was a new file and installed it properly.

Hope that's useful.