PDA

View Full Version : -6308 Cannot Locate a .dll in Merge Module Phase



ratimics
07-30-2002, 03:42 AM
Hi All

When i try to build a relase of my instalation i get the following warning:

"Warning: -6308: mscorsn.dll cannot be located on your system. You can set the path to mscorsn.dll using Tools | Options. The file is part of the Microsoft .NET Framework redistributable. It can be installed by running the InstallShield Developer 7 .NET Update available for download from http://www.installshield.com/products/dotnet.asp"

I have run the update on my computer and have even found the file it is looking for (in C:\WINDOWS\Microsoft.NET\Framework\v1.0.3705) and have tried to put the path in almost every edit box in "Tools | Options" as suggested but still get the warning

Any ideas would be appreciated

Thanks
®:confused:

Art Middlekauff
07-30-2002, 05:39 PM
On the .NET tab of Tools | Options, what path are you putting for InstallUtilLib.dll?

ratimics
07-31-2002, 03:07 AM
Hi Art

Thanks for the prompt reply.

I currently have the path

"C:\WINDOWS\Microsoft.NET\Framework\v1.0.3705"

under the "InstallUtilLib.dll location" option in the .NET tab of Tools|Options.

This is the only place on my harddrive where it currently exists (as confirmed by a search)

Do you think i should copy it to another location and try that?

Thanks
®

ratimics
07-31-2002, 04:54 AM
Hi All

Turns out this problem is connected to my other one (Internal build error)

The mscorn.dll is somehow linked to the framework and only after you have set the locations for Regasm.exe and Installutillib.dll correctly will this error go away

Answer to other problem:
(Under the .NET tab in Tools|Options it asks for the LOCATIONS of Installutillib.dll and regasm.exe so I put the directory where these files are installed (copied from explorer). What it actually wants is a path to this file INCLUDING filename. If you click browse and browse to the directory and choose it, it then gives an error message that this is a folder (but not if you copy it directly there) and you actually need to select the specific file requested

eg for Location of InstallUtilLib.dll you need to put something like:

"C:\WINDOWS\Microsoft.NET\Framework\v1.0.3705\InstallUtilLib.dll"

note the filename.... once you have done this it all works as expected.
)

Sorry for the inconvenience caused
®

:o