PDA

View Full Version : IsProjBlankMMTpl.ism problem -- please fix



jonathanlau
07-27-2002, 06:28 PM
Hi,

I ran into this problem when I was trying to use the template merge module for generating a merge module using the Automation Interface. The "templates" are available in "C:\Program Files\InstallShield\Developer\Support\0409".

I kept running into the following error/warning message:
"An invalid identifier was supplied.
This field may contain letters, digits, underscores (_), or periods (.). The field must begin with a letter or an underscore."

This also occurs when I open up IsProjBlankMMTpl.ism in the IDE. For example, clicking on "General Information" or the "Components" tab will give this error.

This was very frustrating. I guess I should have checked it out in the IDE first, but I assumed that the templates were directly usable. It was tough to isolate the problem using the Automation Interface because it would pop up whenever I tried to "AddComponent" to the project template even when the line was correct.

For now, I will just use a blank merge module that I will first generate in the IDE and then use as my template.